summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-22 17:07:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-22 17:07:21 +0000
commit5a902e430b83326bb7206177b4f662ac6a72ccc1 (patch)
treec3018161bb117971d3332b2eb99638b717667f2f /x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild
parentold (diff)
downloadhistorical-5a902e430b83326bb7206177b4f662ac6a72ccc1.tar.gz
historical-5a902e430b83326bb7206177b4f662ac6a72ccc1.tar.bz2
historical-5a902e430b83326bb7206177b4f662ac6a72ccc1.zip
Version bump.
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild')
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild
new file mode 100644
index 000000000000..0962d42001fe
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-2.99.0-r300.ebuild,v 1.1 2011/12/22 17:07:21 ssuominen Exp $
+
+EAPI=4
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+-3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}