summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-14 14:44:11 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-14 14:44:11 +0000
commit7817f6e89a43ca2e2207045179c226be07494cb7 (patch)
treeb4be76f73461b53df4407d126c210f30151eb9d9 /x11-misc/xfm
parentfixed metadata.xml to have the correct herd (diff)
downloadhistorical-7817f6e89a43ca2e2207045179c226be07494cb7.tar.gz
historical-7817f6e89a43ca2e2207045179c226be07494cb7.tar.bz2
historical-7817f6e89a43ca2e2207045179c226be07494cb7.zip
fixed malloc problem in 1.4.3 for #66133
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'x11-misc/xfm')
-rw-r--r--x11-misc/xfm/ChangeLog8
-rw-r--r--x11-misc/xfm/Manifest10
-rw-r--r--x11-misc/xfm/files/xfm-1.4.3-malloc.patch12
-rw-r--r--x11-misc/xfm/xfm-1.4.3.ebuild9
4 files changed, 35 insertions, 4 deletions
diff --git a/x11-misc/xfm/ChangeLog b/x11-misc/xfm/ChangeLog
index 7066cd38b063..d9b0c9aae517 100644
--- a/x11-misc/xfm/ChangeLog
+++ b/x11-misc/xfm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xfm
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfm/ChangeLog,v 1.4 2004/06/24 22:40:48 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfm/ChangeLog,v 1.5 2005/06/14 14:44:11 smithj Exp $
+
+ 14 Jun 2005; Jonathan Smith <smithj@gentoo.org>
+ +files/xfm-1.4.3-malloc.patch, xfm-1.4.3.ebuild:
+ fixed malloc problem in 1.4.3 for #66133
11 May 2004; Michael Sterrett <mr_bones_@gentoo.org> xfm-1.4.3.ebuild:
fix typo: REAEDME/README (bug #50774)
diff --git a/x11-misc/xfm/Manifest b/x11-misc/xfm/Manifest
index b9c36d3f4620..27244e4b4d88 100644
--- a/x11-misc/xfm/Manifest
+++ b/x11-misc/xfm/Manifest
@@ -1,5 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 15e07e299a96234dfff0e9effdb1c740 ChangeLog 976
MD5 fe402b096905cae8dcb4a503d3a838ac metadata.xml 173
MD5 7e98a1e662f5ec3968667bb05a60b5f6 xfm-1.4.3.ebuild 1098
MD5 bcfae9591c9931439f5bcb29d8c93a94 files/digest-xfm-1.4.3 61
MD5 0f75a007428c6d3d50de93fcdbb67a6f files/xfm-1.4.3-malloc.patch 413
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCru1Xl5AvwDPiUowRAi77AKCm1B5GfV5n3Dyc2HG1NaBOhwFMtACeLKIQ
+GePMx/eqvIctyDBwXtjJ/m8=
+=5qpm
+-----END PGP SIGNATURE-----
diff --git a/x11-misc/xfm/files/xfm-1.4.3-malloc.patch b/x11-misc/xfm/files/xfm-1.4.3-malloc.patch
new file mode 100644
index 000000000000..00607185f1b9
--- /dev/null
+++ b/x11-misc/xfm/files/xfm-1.4.3-malloc.patch
@@ -0,0 +1,12 @@
+diff -Nru --exclude=Makefile xfm-1.4.3.original/regexp/regexp.c xfm-1.4.3/regexp/regexp.c
+--- xfm-1.4.3.original/regexp/regexp.c 2005-05-07 17:36:22.000000000 +0200
++++ xfm-1.4.3/regexp/regexp.c 2005-05-07 17:37:59.000000000 +0200
+@@ -195,7 +195,7 @@
+ register char *longest;
+ register int len;
+ int flags;
+- extern char *malloc();
++ /* extern char *malloc(); */
+
+ if (exp == NULL)
+ FAIL("NULL argument");
diff --git a/x11-misc/xfm/xfm-1.4.3.ebuild b/x11-misc/xfm/xfm-1.4.3.ebuild
index c0fd8690bbd1..dd1edade1162 100644
--- a/x11-misc/xfm/xfm-1.4.3.ebuild
+++ b/x11-misc/xfm/xfm-1.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfm/xfm-1.4.3.ebuild,v 1.3 2004/06/24 22:40:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfm/xfm-1.4.3.ebuild,v 1.4 2005/06/14 14:44:11 smithj Exp $
DESCRIPTION="A classic X11 file manager"
HOMEPAGE="http://www.musikwissenschaft.uni-mainz.de/~ag/xfm/"
@@ -16,6 +16,11 @@ RDEPEND="virtual/x11
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-malloc.patch
+}
+
src_compile() {
sed -i \
-e 's:$(DESTDIR)$(BINDIR):$(BINDIR):g' \