summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-12-04 04:17:11 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-12-04 04:17:11 +0000
commitf5c2f71da5a02b323eb1b65be2517a8bc98ed394 (patch)
treeed798dd08d0a332eb1ad75a52ad3c4a20ab8b249 /sys-apps/kmod/kmod-9999.ebuild
parentRevbump to fix segfault issue with aes-ni support and add epatch_user support... (diff)
downloadhistorical-f5c2f71da5a02b323eb1b65be2517a8bc98ed394.tar.gz
historical-f5c2f71da5a02b323eb1b65be2517a8bc98ed394.tar.bz2
historical-f5c2f71da5a02b323eb1b65be2517a8bc98ed394.zip
Upstream recommended to me that we install the kmod binary in /bin. Also I have put the syminks there except for the compatibility symlinks for the kernel.
Package-Manager: portage-2.2.0_alpha144/cvs/Linux i686 Manifest-Sign-Key: 0x30C46538
Diffstat (limited to 'sys-apps/kmod/kmod-9999.ebuild')
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index fc5764446f72..95d16394f88c 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.40 2012/11/25 09:42:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.41 2012/12/04 04:16:52 williamh Exp $
EAPI=4
@@ -54,14 +54,15 @@ src_prepare()
src_configure()
{
econf \
- --bindir=/sbin \
+ --bindir=/bin \
+ --libdir=/$(get_libdir) \
+ --with-rootlibdir=/$(get_libdir) \
$(use_enable static-libs static) \
$(use_enable tools) \
$(use_enable debug) \
$(use_enable doc gtk-doc) \
$(use_with lzma xz) \
- $(use_with zlib) \
- --with-rootlibdir=/$(get_libdir)
+ $(use_with zlib)
}
src_install()
@@ -71,10 +72,13 @@ src_install()
if use tools; then
local cmd
- for cmd in depmod insmod modinfo modprobe rmmod; do
- dosym kmod /sbin/${cmd}
+ for cmd in depmod insmod lsmod modinfo modprobe rmmod; do
+ dosym kmod /bin/${cmd}
done
- dosym /sbin/kmod /bin/lsmod
+ # Compatibility symlink(s):
+ # These are both hardcoded in the Linux kernel source tree wrt #426698
+ dosym /bin/kmod /sbin/depmod
+ dosym /bin/kmod /sbin/modprobe
fi
cat <<-EOF > "${T}"/usb-load-ehci-first.conf