summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-04 01:11:48 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-04 01:11:48 +0000
commit239810a3096b47b2cc066b684bbf9c812988df51 (patch)
tree630a03366c75c8480e05893ca101c01dceb6ebcf /net-www/phpBB
parentFix for installation problem when apache not yet installed (diff)
downloadhistorical-239810a3096b47b2cc066b684bbf9c812988df51.tar.gz
historical-239810a3096b47b2cc066b684bbf9c812988df51.tar.bz2
historical-239810a3096b47b2cc066b684bbf9c812988df51.zip
Fix for installation problem when apache not yet installed
Diffstat (limited to 'net-www/phpBB')
-rw-r--r--net-www/phpBB/Manifest4
-rw-r--r--net-www/phpBB/phpBB-2.0.4.ebuild10
-rw-r--r--net-www/phpBB/phpBB-2.0.5.ebuild9
3 files changed, 12 insertions, 11 deletions
diff --git a/net-www/phpBB/Manifest b/net-www/phpBB/Manifest
index 966e983ceced..fed6c8a15745 100644
--- a/net-www/phpBB/Manifest
+++ b/net-www/phpBB/Manifest
@@ -1,5 +1,5 @@
-MD5 3b992e4e59d64a10c88bf8f8782ddfea phpBB-2.0.5.ebuild 1354
-MD5 1e182272ecf685584bb82e19e35b9bc6 phpBB-2.0.4.ebuild 1389
+MD5 0beb2c1a6742eda122ccea572bd91afb phpBB-2.0.5.ebuild 1354
+MD5 bbb0796aef054fc603d2cf84cbd70a6c phpBB-2.0.4.ebuild 1389
MD5 e3ffd195d56f5b33813705d1b0a2a438 ChangeLog 528
MD5 1c9cf1de5be80b37285838551452ebf4 files/digest-phpBB-2.0.4 63
MD5 b0e9ee3a18db6416eedbe05a7c409b36 files/digest-phpBB-2.0.5 63
diff --git a/net-www/phpBB/phpBB-2.0.4.ebuild b/net-www/phpBB/phpBB-2.0.4.ebuild
index 167a19b24d7d..a674c478f77a 100644
--- a/net-www/phpBB/phpBB-2.0.4.ebuild
+++ b/net-www/phpBB/phpBB-2.0.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Tim Raedisch <tim.raedisch@udo.edu>
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.4.ebuild,v 1.3 2003/08/03 19:20:42 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.4.ebuild,v 1.4 2003/08/04 01:11:40 stuart Exp $
S=${WORKDIR}/${PN}2
DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
@@ -17,13 +17,11 @@ DEPEND="virtual/php"
# this is the eclass that handles apache-specific stuff
inherit webapp-apache
-
-# these are the functions provided by the webapp eclass solution
-
-webapp-determine-installowner
-webapp-determine-htdocsdir
+webapp-detect || NO_WEBSERVER=1
pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+
if [ -d "${HTTPD_ROOT}/phpbb" ] ; then
ewarn "You need to unmerge your old phpBB version first."
ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
diff --git a/net-www/phpBB/phpBB-2.0.5.ebuild b/net-www/phpBB/phpBB-2.0.5.ebuild
index c42031430ce6..e4351031f374 100644
--- a/net-www/phpBB/phpBB-2.0.5.ebuild
+++ b/net-www/phpBB/phpBB-2.0.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Tim Raedisch <tim.raedisch@udo.edu>
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.5.ebuild,v 1.2 2003/08/03 19:29:07 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.5.ebuild,v 1.3 2003/08/04 01:11:40 stuart Exp $
S=${WORKDIR}/${PN}2
DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
@@ -15,16 +15,19 @@ KEYWORDS="~x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/php"
inherit webapp-apache
-webapp-determine-installowner
-webapp-determine-htdocsdir
+webapp-detect || NO_WEBSERVER=1
pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+
if [ -d ${HTTPD_ROOT}/phpbb ] ; then
ewarn "You need to unmerge your old phpBB version first."
ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
ewarn "directly instead of a version-dependant directory."
die "need to unmerge old version first"
fi
+
+ einfo "Installing for ${WEBAPP_SERVER}"
}
src_compile() {