summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-27 22:09:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-27 22:09:01 +0000
commit3cf1ea52f2709f8e9a2543b986709692f2fb355e (patch)
tree66961f65e548f5ae305f7436c4e32a1cbd3e759f /net-misc
parentFixed bug 45830. Thanks to Antonio <netbix@netbix.net> . (diff)
downloadhistorical-3cf1ea52f2709f8e9a2543b986709692f2fb355e.tar.gz
historical-3cf1ea52f2709f8e9a2543b986709692f2fb355e.tar.bz2
historical-3cf1ea52f2709f8e9a2543b986709692f2fb355e.zip
touchups
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/taylor-uucp/taylor-uucp-1.07.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/net-misc/taylor-uucp/taylor-uucp-1.07.ebuild b/net-misc/taylor-uucp/taylor-uucp-1.07.ebuild
index f0cb278f408c..18e51da1d82d 100644
--- a/net-misc/taylor-uucp/taylor-uucp-1.07.ebuild
+++ b/net-misc/taylor-uucp/taylor-uucp-1.07.ebuild
@@ -1,32 +1,36 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/taylor-uucp/taylor-uucp-1.07.ebuild,v 1.10 2004/03/13 20:06:29 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/taylor-uucp/taylor-uucp-1.07.ebuild,v 1.11 2004/03/27 22:09:01 vapier Exp $
+
+inherit eutils
S=${WORKDIR}/uucp-1.07 # This should be a .2 bug the package is messed
DESCRIPTION="Taylor UUCP"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/uucp/uucp-${PV}.tar.gz"
HOMEPAGE="http://www.airs.com/ian/uucp.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/uucp/uucp-${PV}.tar.gz"
-KEYWORDS="x86 sparc alpha ~amd64 ia64 ~ppc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha ~amd64 ia64"
DEPEND="virtual/glibc"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/gentoo-uucp-${PV}.patch
- sh configure --prefix=/usr \
- --with-newconfigdir=/etc/uucp
+}
+
+src_compile() {
+ econf --with-newconfigdir=/etc/uucp || die
make || die
}
src_install() {
- dodir /usr/share/man/man1
- dodir /usr/share/man/man8
+ dodir /usr/share/man/man{1,8}
dodir /usr/share/info
dodir /etc/uucp
- dodir /usr/bin
- dodir /usr/sbin
+ dodir /usr/bin /usr/sbin
dodir /var/log/uucp
dodir /var/lock/uucp
make \
@@ -39,7 +43,7 @@ src_install() {
infodir=${D}/usr/share/info \
install install-info || die
cp sample/* ${D}/etc/uucp
- dodoc COPYING ChangeLog NEWS README TODO
+ dodoc ChangeLog NEWS README TODO
chmod -R 775 ${D}/var/lock/uucp
chown -R root:uucp ${D}/var/lock/uucp