summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-09-15 06:34:40 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-09-15 06:34:40 +0000
commitf87b54ebd0437d37391de83f54ae6b9bdb60cbbf (patch)
treef437eb50975dc2cd6f165b1381518bff7950d430 /media-tv
parentUpdate /etc/modules.d file (diff)
downloadhistorical-f87b54ebd0437d37391de83f54ae6b9bdb60cbbf.tar.gz
historical-f87b54ebd0437d37391de83f54ae6b9bdb60cbbf.tar.bz2
historical-f87b54ebd0437d37391de83f54ae6b9bdb60cbbf.zip
Detect more modules that need to go to make everything happy
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog5
-rw-r--r--media-tv/ivtv/Manifest10
-rw-r--r--media-tv/ivtv/ivtv-0.3.8.ebuild19
3 files changed, 21 insertions, 13 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 97780ec044cb..b5a3534f3954 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.31 2005/09/15 05:53:56 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.32 2005/09/15 06:34:40 cardoe Exp $
+
+ 15 Sep 2005; Doug Goldstein <cardoe@gentoo.org> ivtv-0.3.8.ebuild:
+ Detect more modules that need to go to make everything happy
*ivtv-0.3.8 (15 Sep 2005)
diff --git a/media-tv/ivtv/Manifest b/media-tv/ivtv/Manifest
index 6eb9096b750b..098fd76eaed3 100644
--- a/media-tv/ivtv/Manifest
+++ b/media-tv/ivtv/Manifest
@@ -1,8 +1,8 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 c1e598bb799c5236e53b57a8c386c185 ChangeLog 4733
-MD5 81c8de3519498bf234585646c05fe005 ivtv-0.3.8.ebuild 3416
+MD5 a533e4b4d55cd8d9ba1e7d81e5d111a6 ChangeLog 4866
+MD5 4b7fb5a7d3cfcc8351c72491457ca790 ivtv-0.3.8.ebuild 3608
MD5 1b5dfd233a54a22de87bcb47627a7265 ivtv-0.2.0_rc3-r4.ebuild 3964
MD5 71007461e2e10f367a6a8f7a0b0d7d6a metadata.xml 465
MD5 28b327ad3b268ad20a14a516c72e9908 ivtv-0.2.0_rc3-r5.ebuild 3964
@@ -13,7 +13,7 @@ MD5 5458ad51769cecb853e0afb00ab63930 files/digest-ivtv-0.2.0_rc3-r5 134
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDKQ8VBtvusYtCZMsRAlisAJ4+F9h04DbYg4m9QCbcYbemnXuY5wCeOyI6
-64vGkr/sz4DCNf5Q/oKsr1A=
-=OcGX
+iD8DBQFDKRYlBtvusYtCZMsRAp2+AJwIPex/M8BrQUFRyiRefjLvdGpDzwCgg/i5
+jiHbyFXFrYzBadh5CefvOaU=
+=pM+t
-----END PGP SIGNATURE-----
diff --git a/media-tv/ivtv/ivtv-0.3.8.ebuild b/media-tv/ivtv/ivtv-0.3.8.ebuild
index ee506670e7a2..4e8e346a3b8c 100644
--- a/media-tv/ivtv/ivtv-0.3.8.ebuild
+++ b/media-tv/ivtv/ivtv-0.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.3.8.ebuild,v 1.1 2005/09/15 05:53:56 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.3.8.ebuild,v 1.2 2005/09/15 06:34:40 cardoe Exp $
inherit eutils linux-mod
@@ -47,7 +47,7 @@ src_unpack() {
# instead PIO is used. Also, it force enables -fsigned-char and does not
# build some modules that contain x86 asm.
- use ppc && epatch ${FILESDIR}/ppc-odw.patch || die "ppc patch failed"
+ use ppc && epatch ${FILESDIR}/ppc-odw.patch
}
src_compile() {
@@ -107,9 +107,14 @@ pkg_postinst() {
echo
# Similar checks are performed by the make install in the drivers directory.
-
- if [ -f "${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/msp3400.ko" ] ; then
- ewarn "You have the msp3400 module that comes with the kernel. It isn't compatible"
- ewarn "with ivtv. You need to back it up to somewhere else, then run 'update-modules'"
- fi
+ BADMODS="msp3400 tda9887 tuner tveeprom saa7115 saa7127"
+
+ for MODNAME in ${BADMODS}; do
+ if [ -f "${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko" ] ; then
+ ewarn "You have the ${MODNAME} module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run 'update-modules'"
+ ewarn "The file to remove is ${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko"
+ echo
+ fi
+ done
}