summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
commitd29884cbf69b1d20f706e7cb74556184f69a27c6 (patch)
tree63d2775573a7343ae9e8319af0b6747590883b8a /media-sound/moc
parentUnmask KDE 3.5. (diff)
downloadhistorical-d29884cbf69b1d20f706e7cb74556184f69a27c6.tar.gz
historical-d29884cbf69b1d20f706e7cb74556184f69a27c6.tar.bz2
historical-d29884cbf69b1d20f706e7cb74556184f69a27c6.zip
Diffstat (limited to 'media-sound/moc')
-rw-r--r--media-sound/moc/files/digest-moc-2.3.11
-rw-r--r--media-sound/moc/files/moc-2.3.1-configure.patch85
-rw-r--r--media-sound/moc/moc-2.3.1.ebuild65
3 files changed, 151 insertions, 0 deletions
diff --git a/media-sound/moc/files/digest-moc-2.3.1 b/media-sound/moc/files/digest-moc-2.3.1
new file mode 100644
index 000000000000..49e569a12a5e
--- /dev/null
+++ b/media-sound/moc/files/digest-moc-2.3.1
@@ -0,0 +1 @@
+MD5 f6c9d56a80eb8000cfe51997b27eb6ed moc-2.3.1.tar.bz2 403800
diff --git a/media-sound/moc/files/moc-2.3.1-configure.patch b/media-sound/moc/files/moc-2.3.1-configure.patch
new file mode 100644
index 000000000000..58dcd6745994
--- /dev/null
+++ b/media-sound/moc/files/moc-2.3.1-configure.patch
@@ -0,0 +1,85 @@
+--- configure.in.old 2005-08-02 05:30:23.000000000 +0900
++++ configure.in 2005-10-03 23:54:27.000000000 +0900
+@@ -76,19 +76,26 @@
+ [EXTRA_LIBS="$EXTRA_LIBS -lossaudio"])
+ fi
+
+-PKG_CHECK_MODULES(ALSA, [alsa >= 0.9],
+- [COMPILE_ALSA="yes"
+- EXTRA_OBJS="$EXTRA_OBJS alsa.o"
+- AC_DEFINE([HAVE_ALSA], 1, [Define if you have ALSA.])
+- EXTRA_LIBS="$EXTRA_LIBS $ALSA_LIBS"
+- CFLAGS="$CFLAGS $ALSA_CFLAGS"],
+- [COMPILE_ALSA="no"])
++AC_ARG_WITH(jack, AS_HELP_STRING(--without-jack, Compile without JACK support.))
++
++if test "$with_jack" != "xno"
++then
++ PKG_CHECK_MODULES([ALSA], [alsa >= 0.9],
++ [COMPILE_ALSA="yes"
++ EXTRA_OBJS="$EXTRA_OBJS alsa.o"
++ AC_DEFINE([HAVE_ALSA], 1, [Define if you have ALSA.])
++ EXTRA_LIBS="$EXTRA_LIBS $ALSA_LIBS"
++ CFLAGS="$CFLAGS $ALSA_CFLAGS"],
++ [COMPILE_ALSA="no"])
++else
++ COMPILE_ALSA="no"
++fi
+
+ AC_ARG_WITH(jack, AS_HELP_STRING(--without-jack, Compile without JACK support.))
+
+ if test "x$with_jack" != "xno"
+ then
+- PKG_CHECK_MODULES(JACK, [jack >= 0.4],
++ PKG_CHECK_MODULES([JACK], [jack >= 0.4],
+ [COMPILE_JACK="yes"
+ EXTRA_OBJS="$EXTRA_OBJS jack.o"
+ AC_DEFINE([HAVE_JACK], 1, [Define if you have JACK.])
+@@ -214,9 +221,8 @@
+ taglib_ver_minor=`echo "$taglib_ver" | awk -F. '{print $2}'`
+ taglib_ver_extra=`echo "$taglib_ver" | awk -F. '{print $3}'`
+
+- if test \( "$taglib_ver_major" = "1" -a "$taglib_ver_minor" -ge 4 \) \
+- -o \( "$taglib_ver_major" = "1" -a "$taglib_ver_minor" = "3" \
+- -a "$taglib_ver_extra" -ge 1 \)
++ if test \( "$taglib_ver_major" = "1" -a \
++ "$taglib_ver_minor" -ge 4 \)
+ then
+ AC_MSG_RESULT([$taglib_ver, OK])
+
+@@ -248,7 +254,7 @@
+ AC_ARG_WITH(ogg, AS_HELP_STRING(--without-ogg,Compile without OGG support.))
+ if test "x$with_ogg" != "xno"
+ then
+- PKG_CHECK_MODULES(OGG_VORBIS, [ogg >= 1.0 vorbis >= 1.0 vorbisfile >= 1.0],
++ PKG_CHECK_MODULES([OGG_VORBIS], [ogg >= 1.0 vorbis >= 1.0 vorbisfile >= 1.0],
+ [AC_SUBST(OGG_VORBIS_LIBS)
+ AC_SUBST(OGG_VORBIS_CFLAGS)
+ DECODER_PLUGINS="$DECODER_PLUGINS ogg"],
+@@ -269,7 +275,7 @@
+ Compile without libsndfile))
+ if test "x$with_sndfile" != "xno"
+ then
+- PKG_CHECK_MODULES(sndfile, sndfile >= 1.0.0,
++ PKG_CHECK_MODULES([sndfile], [sndfile >= 1.0.0],
+ [AC_SUBST(sndfile_LIBS)
+ AC_SUBST(sndfile_CFLAGS)
+ DECODER_PLUGINS="$DECODER_PLUGINS sndfile"],
+@@ -281,7 +287,7 @@
+ Compile without speex support))
+ if test "x$with_speex" != "xno"
+ then
+- PKG_CHECK_MODULES(speex, speex >= 1.0.0,
++ PKG_CHECK_MODULES([speex], [speex >= 1.0.0],
+ [AC_SUBST(speex_LIBS)
+ AC_SUBST(speex_CFLAGS)
+ DECODER_PLUGINS="$DECODER_PLUGINS speex"],
+@@ -294,7 +300,7 @@
+ COMPILE_SAMPLERATE="no"
+ if test "x$with_samplerate" != "xno"
+ then
+- PKG_CHECK_MODULES(samplerate, samplerate >= 0.1.0,
++ PKG_CHECK_MODULES([samplerate], [samplerate >= 0.1.0],
+ [EXTRA_LIBS="$EXTRA_LIBS $samplerate_LIBS"
+ CFLAGS="$CFLAGS $samplerate_CFLAGS"
+ AC_DEFINE([HAVE_SAMPLERATE], 1,
diff --git a/media-sound/moc/moc-2.3.1.ebuild b/media-sound/moc/moc-2.3.1.ebuild
new file mode 100644
index 000000000000..1ce1de693252
--- /dev/null
+++ b/media-sound/moc/moc-2.3.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/moc-2.3.1.ebuild,v 1.1.1.1 2005/11/30 09:38:29 chriswhite Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Music On Console - ncurses interface for playing audio files"
+HOMEPAGE="http://moc.daper.net/"
+SRC_URI="ftp://ftp.daper.net/pub/soft/${PN}/stable/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="flac jack muse mad oss vorbis debug alsa speex libsamplerate curl sndfile muse"
+
+# libvorbis is pulled in so the USE flag is vorbis
+# since upstream apparently assumes ogg is an audio
+# codec
+DEPEND="media-libs/libao
+ sys-libs/ncurses
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ sndfile? ( >=media-libs/libsndfile-1.0.0 )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad sys-libs/zlib media-libs/libid3tag )
+ muse? ( media-libs/libmpcdec >=media-libs/taglib-1.3 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.4 )
+ speex? ( >=media-libs/speex-1.0.0 )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.0 )
+ curl? ( >=net-misc/curl-7.12.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # big configure fixes
+ epatch ${FILESDIR}/${P}-configure.patch
+ AT_M4DIR="m4"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with flac) \
+ $(use_with mad mp3) \
+ $(use_with vorbis ogg) \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with muse musepack) \
+ $(use_enable debug) \
+ $(use_with sndfile) \
+ $(use_with libsamplerate samplerate) \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "The binary was renamed due to conflicts with moc"
+ einfo "from the QT project. Its new name is mocp."
+}