summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:24:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:24:22 +0000
commitcffaa40e706892b18a581ac8ca8d08b70b5edd0f (patch)
treeb4b1419981fac9d0277bcbb1f828c2e40c8d4ff4 /kde-base/kontact/kontact-4.14.3.ebuild
parentremove old (diff)
downloadhistorical-cffaa40e706892b18a581ac8ca8d08b70b5edd0f.tar.gz
historical-cffaa40e706892b18a581ac8ca8d08b70b5edd0f.tar.bz2
historical-cffaa40e706892b18a581ac8ca8d08b70b5edd0f.zip
[kde-base] Add KDE SC 4.14.3
Package-Manager: portage-2.2.14/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0xF82F92E6
Diffstat (limited to 'kde-base/kontact/kontact-4.14.3.ebuild')
-rw-r--r--kde-base/kontact/kontact-4.14.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-base/kontact/kontact-4.14.3.ebuild b/kde-base/kontact/kontact-4.14.3.ebuild
new file mode 100644
index 000000000000..be3468ec5560
--- /dev/null
+++ b/kde-base/kontact/kontact-4.14.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.14.3.ebuild,v 1.1 2014/11/16 12:21:33 alexxy Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+HOMEPAGE="http://www.kde.org/applications/office/kontact/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="kdepim-common-libs"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+KMEXTRACTONLY="
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ libkdepimdbusinterfaces/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}