summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 16:28:57 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 16:28:57 +0000
commit9bd03a1d46c998b6c6468a437ec6ac6564094136 (patch)
tree3c5086e459a60d690d2a7f5e644fa516f8feebf4 /kde-base/kdebindings-ruby
parentInitial commit of screengrab application. Fixes bug #307093 (diff)
downloadhistorical-9bd03a1d46c998b6c6468a437ec6ac6564094136.tar.gz
historical-9bd03a1d46c998b6c6468a437ec6ac6564094136.tar.bz2
historical-9bd03a1d46c998b6c6468a437ec6ac6564094136.zip
Version bump KDE 4.4.1
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdebindings-ruby')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog8
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.4.1.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
index ee9a29bf7b52..1f854c54c9cd 100644
--- a/kde-base/kdebindings-ruby/ChangeLog
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.3 2010/02/10 21:39:17 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.4 2010/03/02 16:22:55 tampakrap Exp $
+
+*kdebindings-ruby-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdebindings-ruby-4.4.1.ebuild:
+ Version bump
10 Feb 2010; Jonathan Callen <abcd@gentoo.org>
kdebindings-ruby-4.4.0.ebuild, metadata.xml:
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.1.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.1.ebuild
new file mode 100644
index 000000000000..834181fb8e60
--- /dev/null
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.1.ebuild,v 1.1 2010/03/02 16:22:55 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="ruby"
+WEBKIT_REQUIRED="optional"
+
+USE_RUBY="ruby18"
+
+inherit kde4-meta ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="akonadi debug kdevplatform okular phonon plasma qscintilla qwt semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep smoke 'akonadi?,kdevplatform?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?')
+"
+
+RDEPEND="${DEPEND}
+ !dev-ruby/qt4-qtruby
+"
+
+KMEXTRACTONLY="
+ ruby/krossruby
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-linkage.patch
+)
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ kde4-meta_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i -e "s#smoke/smoke.h#smoke.h#" \
+ ruby/qtruby/src/handlers.cpp \
+ ruby/qtruby/src/marshall.h \
+ ruby/qtruby/src/marshall_types.h \
+ ruby/qtruby/src/Qt.cpp \
+ ruby/qtruby/src/qtruby.cpp \
+ ruby/qtruby/src/qtruby.h \
+ ruby/qtruby/src/smokeruby.h || die
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ $(cmake-utils_use_enable akonadi KdepimLibs)
+ $(cmake-utils_use_enable akonadi)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_RUBY)
+ $(cmake-utils_use_enable kdevplatform KDevPlatform)
+ $(cmake-utils_use_with kdevplatform KDevPlatform)
+ $(cmake-utils_use_enable okular)
+ $(cmake-utils_use_enable plasma PLASMA_RUBY)
+ $(cmake-utils_use_enable phonon)
+ $(cmake-utils_use_enable phonon PHONON_RUBY)
+ $(cmake-utils_use_enable qscintilla QScintilla)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_RUBY)
+ $(cmake-utils_use_enable qwt QWT_RUBY)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable semantic-desktop SOPRANO_RUBY)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable webkit QTWEBKIT_RUBY)
+ -DENABLE_KROSSRUBY=OFF
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ )
+ kde4-meta_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_install
+}