summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-12 06:11:55 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-12 06:11:55 +0000
commit13aac5b116416a8cc974f93b539e2486313dcaeb (patch)
tree6e51d32fd0f483fa83ff942b3a985b7a2239020f /games-strategy/xconq
parentalsa-1.0.0 fix #35522 (diff)
downloadhistorical-13aac5b116416a8cc974f93b539e2486313dcaeb.tar.gz
historical-13aac5b116416a8cc974f93b539e2486313dcaeb.tar.bz2
historical-13aac5b116416a8cc974f93b539e2486313dcaeb.zip
initial ebuild #28964
Diffstat (limited to 'games-strategy/xconq')
-rw-r--r--games-strategy/xconq/ChangeLog8
-rw-r--r--games-strategy/xconq/files/digest-xconq-7.4.11
-rw-r--r--games-strategy/xconq/xconq-7.4.1.ebuild36
3 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/xconq/ChangeLog b/games-strategy/xconq/ChangeLog
new file mode 100644
index 000000000000..f1f11cd86871
--- /dev/null
+++ b/games-strategy/xconq/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-strategy/xconq
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.1 2003/12/12 06:11:55 vapier Exp $
+
+*xconq-7.4.1 (12 Dec 2003)
+
+ 12 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for #28964.
diff --git a/games-strategy/xconq/files/digest-xconq-7.4.1 b/games-strategy/xconq/files/digest-xconq-7.4.1
new file mode 100644
index 000000000000..de1288573b4e
--- /dev/null
+++ b/games-strategy/xconq/files/digest-xconq-7.4.1
@@ -0,0 +1 @@
+MD5 c266e182c8f3454730ec4314e5d7b8aa xconq-7.4.1.tar.gz 3402832
diff --git a/games-strategy/xconq/xconq-7.4.1.ebuild b/games-strategy/xconq/xconq-7.4.1.ebuild
new file mode 100644
index 000000000000..bc7ee13eb43c
--- /dev/null
+++ b/games-strategy/xconq/xconq-7.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.1 2003/12/12 06:11:55 vapier Exp $
+
+inherit games
+
+DESCRIPTION="a general strategy game system"
+HOMEPAGE="http://sources.redhat.com/xconq/"
+SRC_URI="ftp://sources.redhat.com/pub/xconq/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ dev-lang/tk
+ dev-lang/tcl"
+
+src_compile() {
+ egamesconf \
+ --enable-alternate-scoresdir=${GAMES_STATEDIR}/${PN}/scores \
+ || die
+ emake \
+ CFLAGS="${CFLAGS}" \
+ datadir=${GAMES_DATADIR}/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ dodir ${GAMES_STATEDIR}/${PN} ${GAMES_DATADIR}/${PN}
+ egamesinstall \
+ scoresdir=${D}/${GAMES_STATEDIR}/${PN}/scores \
+ datadir=${D}/${GAMES_DATADIR}/${PN} \
+ || die
+ prepgamesdirs
+}