summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-12 00:01:24 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-12 00:01:24 +0000
commitf220a8c1c3663c4f4af5ca79b02b0f3a8f5be188 (patch)
treee2fe36278d056da569514b3e00d9d9b62aef71d1 /games-simulation
parentEnsure enigmail connects to gpg agent, bug #373733 (diff)
downloadhistorical-f220a8c1c3663c4f4af5ca79b02b0f3a8f5be188.tar.gz
historical-f220a8c1c3663c4f4af5ca79b02b0f3a8f5be188.tar.bz2
historical-f220a8c1c3663c4f4af5ca79b02b0f3a8f5be188.zip
Initial import
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/crrcsim/ChangeLog11
-rw-r--r--games-simulation/crrcsim/Manifest15
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.11.ebuild39
-rw-r--r--games-simulation/crrcsim/files/crrcsim-buildsystem.patch38
-rw-r--r--games-simulation/crrcsim/metadata.xml10
5 files changed, 113 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/ChangeLog b/games-simulation/crrcsim/ChangeLog
new file mode 100644
index 000000000000..bf90971c5dd7
--- /dev/null
+++ b/games-simulation/crrcsim/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-simulation/crrcsim
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.1 2011/11/12 00:01:24 xmw Exp $
+
+*crrcsim-0.9.11 (11 Nov 2011)
+
+ 11 Nov 2011; Michael Weber <xmw@gentoo.org> +crrcsim-0.9.11.ebuild,
+ +files/crrcsim-buildsystem.patch, +metadata.xml:
+ Initial import (thanks to Piotr Szymaniak and Krzysztof Synowiec for the
+ report, bug 227273)
+
diff --git a/games-simulation/crrcsim/Manifest b/games-simulation/crrcsim/Manifest
new file mode 100644
index 000000000000..8430fd1409d5
--- /dev/null
+++ b/games-simulation/crrcsim/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+AUX crrcsim-buildsystem.patch 1222 RMD160 bc15b8a60db0096075140b1d4bf804da59a6af89 SHA1 496f821cac0948ffa5395b1a510fda8b89916486 SHA256 0fdf065a2a7bcfe13999b6ab3a4a9764ff3e53b152d25d0f8ab976245def470f
+DIST crrcsim-0.9.11.tar.gz 6779165 RMD160 301e1a5fbface0ecfce7910c557a1fb8a2f01d47 SHA1 7e1b9ce9a5ad0f2b878ff422e00f8a3e28dc0f8d SHA256 3f42582623613ebc112b9c124d2905da4b90789b48c6c930052201737b7ce99b
+EBUILD crrcsim-0.9.11.ebuild 873 RMD160 7391aa9e3aca00058d7158bb358f6aa095e8d237 SHA1 2f146c28bb239c3d1db80861e99e7678c289432d SHA256 040c78cf41a99f6d64dbf7ac2e142c90e44aa8e47b97bfa8a320856c72e67470
+MISC ChangeLog 468 RMD160 f43ef528c5a2d030704acceddfc3028044cfa90c SHA1 a406a24e5ebc028cfe94acac207b413a8986d77b SHA256 d8e86cf9799472d7828c70713361192a900786ba0c37d1d4940602a296bf69cf
+MISC metadata.xml 243 RMD160 61a73b3edc5d56dfe9ee302cc4c70f56a96eed78 SHA1 00fc0791a913c7c2a57718c9019f6ec0cf582326 SHA256 89106787a5945407ba66d216c4d1ade48c419f09c5f13933be3bb92657dad8b0
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk69t1oACgkQknrdDGLu8JCCmwEAlPNxCA5mslzZlwq1jobHPpr8
+wNt/tgpAlNq+xLiWURQBAIRm9p5n2nRDBHu6Nz332/ymL35e93NDUO1rR81lzvey
+=LWMA
+-----END PGP SIGNATURE-----
diff --git a/games-simulation/crrcsim/crrcsim-0.9.11.ebuild b/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
new file mode 100644
index 000000000000..46c548747bf3
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.11.ebuild,v 1.1 2011/11/12 00:01:24 xmw Exp $
+
+EAPI=3
+
+inherit autotools eutils games
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="http://crrcsim.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="media-libs/plib
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-buildsystem.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with poraudio) $(use_with sdl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS HISTORY NEWS README || die
+
+ prepgamesdirs
+}
diff --git a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
new file mode 100644
index 000000000000..824add723a53
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
@@ -0,0 +1,38 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -79,8 +79,12 @@
+ dnl Default is: no portaudio present
+ portaudio=0
+
++AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
++
++AS_IF([test "x$with_portaudio" != "xno"], [
+ dnl Check for the Portaudio header file
+ AC_CHECK_HEADER([portaudio.h])
++])
+
+ if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
+ dnl Check for Portaudio 18
+@@ -116,9 +120,11 @@
+ fi
+ AC_SUBST(PA_LIBS)
+
++AC_ARG_WITH([sdl], AS_HELP_STRING([--without-sdl], [Build without sdl library (default: test)]))
+ dnl Search for SDL 1.2.5 or newer
+ SDL_VERSION=1.2.5
+ sdl_mousewheel="yes (SDL >= 1.2.5)"
++AS_IF([test "x$with_foo" != "xno"], [
+ AM_PATH_SDL($SDL_VERSION,:,AC_MSG_NOTICE([*** SDL version $SDL_VERSION or newer not found! See if at least 1.2.0 is present...]))
+ if test "x$no_sdl" = "xyes"
+ then
+@@ -129,6 +135,10 @@
+ AC_DEFINE([SDL_WITHOUT_MOUSEWHEEL], [1], [SDL < 1.2.5 did not feature mousewheel button macros])
+ sdl_mousewheel="no (SDL < 1.2.5)"
+ fi
++])
++AS_IF([test "x$with_foo" != "xyes"], [
++ AC_DEFINE([SDL_WITHOUT_MOUSEWHEEL], [1], [SDL disabled])
++])
+ AC_SUBST(SDL_LIBS)
+ AC_SUBST(SDL_CFLAGS)
+
diff --git a/games-simulation/crrcsim/metadata.xml b/games-simulation/crrcsim/metadata.xml
new file mode 100644
index 000000000000..a562c4775bb2
--- /dev/null
+++ b/games-simulation/crrcsim/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+