summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-30 20:26:32 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-30 20:26:32 +0000
commit7296f5149d92af008cb0adcbf29fc5c6e3aa29ae (patch)
tree18c9e295d2ac2015f53e83af73e0dcdeba9775f4 /dev-ruby/prawn-layout
parentAdd Ruby 1.9 support. (diff)
downloadhistorical-7296f5149d92af008cb0adcbf29fc5c6e3aa29ae.tar.gz
historical-7296f5149d92af008cb0adcbf29fc5c6e3aa29ae.tar.bz2
historical-7296f5149d92af008cb0adcbf29fc5c6e3aa29ae.zip
Remove old version.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/prawn-layout')
-rw-r--r--dev-ruby/prawn-layout/ChangeLog6
-rw-r--r--dev-ruby/prawn-layout/prawn-layout-0.1.0.ebuild83
2 files changed, 5 insertions, 84 deletions
diff --git a/dev-ruby/prawn-layout/ChangeLog b/dev-ruby/prawn-layout/ChangeLog
index 73ff16a38d90..c3733b0ba4b7 100644
--- a/dev-ruby/prawn-layout/ChangeLog
+++ b/dev-ruby/prawn-layout/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/prawn-layout
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/ChangeLog,v 1.4 2010/02/01 09:23:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/ChangeLog,v 1.5 2010/04/30 20:25:05 graaff Exp $
+
+ 30 Apr 2010; Hans de Graaff <graaff@gentoo.org>
+ -prawn-layout-0.1.0.ebuild:
+ Remove old version.
*prawn-layout-0.7.2 (01 Feb 2010)
diff --git a/dev-ruby/prawn-layout/prawn-layout-0.1.0.ebuild b/dev-ruby/prawn-layout/prawn-layout-0.1.0.ebuild
deleted file mode 100644
index 6f21793382a8..000000000000
--- a/dev-ruby/prawn-layout/prawn-layout-0.1.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/prawn-layout-0.1.0.ebuild,v 1.1 2009/07/16 13:28:53 flameeyes Exp $
-
-EAPI=2
-
-GITHUB_USER=sandal
-
-inherit ruby
-
-DESCRIPTION="An extension to Prawn offering table support, grid layouts and other things"
-HOMEPAGE="http://github.com/${GITHUB_USER}/${PN}/tree/master"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples test"
-
-SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${PV} -> ${P}.tgz"
-
-USE_RUBY="ruby18"
-
-RDEPEND="dev-ruby/prawn"
-DEPEND="doc? ( dev-ruby/rake )
- test? (
- dev-ruby/rake
- dev-ruby/mocha
- ${RDEPEND}
- )"
-
-S="${WORKDIR}"
-
-src_compile() {
- cd "${WORKDIR}"/${GITHUB_USER}-${PN}-*
-
- if use doc; then
- rake rdoc || die "rake rdoc failed"
- fi
-}
-
-src_test() {
- cd "${WORKDIR}"/${GITHUB_USER}-${PN}-*
-
- rake test || die "rake test failed"
-}
-
-dofakegemspec() {
- cat - > "${T}"/${P}.gemspec <<EOF
-Gem::Specification.new do |s|
- s.name = "${PN}"
- s.version = "${PV}"
- s.summary = "${DESCRIPTION}"
- s.homepage = "${HOMEPAGE}"
-end
-EOF
-
- # Note: this only works with 1.8 so if you need to make it work
- # with 1.9 you better wait for ruby-fakegem.eclass.
- insinto $(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')/../gems/1.8/specifications
- doins "${T}"/${P}.gemspec || die "Unable to install fake gemspec"
-}
-
-src_install() {
- cd "${WORKDIR}"/${GITHUB_USER}-${PN}-*
-
- pushd lib
- doruby -r * || die "install lib failed"
- popd
-
- dofakegemspec
-
- if use doc; then
- docinto apidocs
- pushd doc
- dohtml -r * || die "Installing html documentation failed."
- popd
- fi
-
- if use examples; then
- docinto examples
- dodoc -r examples/* || die "Installing examples failes."
- fi
-}