summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-07-09 13:30:05 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-07-09 13:30:05 +0000
commitddb15cc1d4c396bbb4c98c22ab326584353bdc2a (patch)
treeecb7f8438c31a23a2c22122e6858c3183b294d8b /dev-python
parentClean out older stable versions (diff)
downloadhistorical-ddb15cc1d4c396bbb4c98c22ab326584353bdc2a.tar.gz
historical-ddb15cc1d4c396bbb4c98c22ab326584353bdc2a.tar.bz2
historical-ddb15cc1d4c396bbb4c98c22ab326584353bdc2a.zip
Remove old.
Package-Manager: portage-2.2.0_alpha116/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog6
-rw-r--r--dev-python/PyQt4/PyQt4-4.8.1.ebuild172
-rw-r--r--dev-python/PyQt4/files/PyQt4-4.6.1-configure-multilib.patch13
-rw-r--r--dev-python/sip/ChangeLog5
-rw-r--r--dev-python/sip/sip-4.11.2.ebuild77
5 files changed, 9 insertions, 264 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 10476de8b3dc..26b5841a51b0 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.190 2012/07/08 18:28:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.191 2012/07/09 13:25:50 pesa Exp $
+
+ 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
+ -files/PyQt4-4.6.1-configure-multilib.patch:
+ Remove old.
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
PyQt4-4.9.4.ebuild:
diff --git a/dev-python/PyQt4/PyQt4-4.8.1.ebuild b/dev-python/PyQt4/PyQt4-4.8.1.ebuild
deleted file mode 100644
index bdc8b95851a9..000000000000
--- a/dev-python/PyQt4/PyQt4-4.8.1.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.8.1.ebuild,v 1.21 2012/06/14 07:22:35 yngwin Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
-
-inherit eutils python qt4-r2 toolchain-funcs
-
-MY_P="PyQt-x11-gpl-${PV/_pre/-snapshot-}"
-
-# Minimal supported version of Qt.
-QT_VER="4.6.2"
-
-DESCRIPTION="Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ http://pypi.python.org/pypi/PyQt"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="X assistant +dbus debug doc examples kde multimedia opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND="<dev-python/sip-4.13
- >=x11-libs/qt-core-${QT_VER}:4
- >=x11-libs/qt-script-${QT_VER}:4
- >=x11-libs/qt-test-${QT_VER}:4
- X? ( >=x11-libs/qt-gui-${QT_VER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QT_VER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QT_VER}:4
- )
- multimedia? ( >=x11-libs/qt-multimedia-${QT_VER}:4 )
- opengl? ( >=x11-libs/qt-opengl-${QT_VER}:4 || ( >=x11-libs/qt-opengl-4.7.0:4[-egl] <x11-libs/qt-opengl-4.7.0:4 ) )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QT_VER}:4 media-libs/phonon ) )
- kde? ( media-libs/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QT_VER}:4 )
- svg? ( >=x11-libs/qt-svg-${QT_VER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QT_VER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QT_VER}:4 )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.6.1-configure-multilib.patch"
- "${FILESDIR}/${PN}-4.7.2-configure.py.patch"
-)
-
-src_prepare() {
- if ! use dbus; then
- sed -e "s/^\([[:blank:]]\+\)check_dbus()/\1pass/" -i configure.py || die "sed configure.py failed"
- fi
-
- # Support qreal for arm architecture (bug #322349).
- use arm && epatch "${FILESDIR}/${PN}-4.7.3-qreal_float_support.patch"
-
- qt4-r2_src_prepare
-
- # Use proper include directory.
- sed -e "s:/usr/include:${EPREFIX}/usr/include:g" -i configure.py || die "sed configure.py failed"
-
- python_copy_sources
-
- preparation() {
- if [[ "$(python_get_version --major)" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_execute_function -s preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- --confirm-license
- --bindir="${EPREFIX}/usr/bin"
- --destdir="${EPREFIX}$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- --qsci-api
- $(use debug && echo --debug)
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable X QtScriptTools)
- # QtAssistant module is not available with Qt >=4.7.0.
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable multimedia QtMultimedia)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- CFLAGS="${CFLAGS}"
- CXXFLAGS="${CXXFLAGS}"
- LFLAGS="${LDFLAGS}")
- echo "${myconf[@]}"
- "${myconf[@]}" || return 1
-
- local mod
- for mod in QtCore $(use X && echo QtDesigner QtGui); do
- # Run eqmake4 inside the qpy subdirectories to avoid stripping and many other QA issues.
- pushd qpy/${mod} > /dev/null || return 1
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || return 1
-
- # Fix insecure runpaths.
- sed -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" -i ${mod}/Makefile || die "Fixing of rpaths failed"
- done
-
- # Fix pre-stripping of libpythonplugin.so
- if use X; then
- cd "${BUILDDIR}/designer"
- eqmake4 python.pro
- fi
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_src_compile
-}
-
-src_install() {
- installation() {
- # INSTALL_ROOT is needed for the QtDesigner module, other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- }
- python_execute_function -s installation
-
- dodoc doc/pyqt4ref.txt NEWS THANKS || die "dodoc failed"
-
- if use doc; then
- dohtml -r doc/* || die "dohtml failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "doins failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize PyQt4
-}
-
-pkg_postrm() {
- python_mod_cleanup PyQt4
-}
diff --git a/dev-python/PyQt4/files/PyQt4-4.6.1-configure-multilib.patch b/dev-python/PyQt4/files/PyQt4-4.6.1-configure-multilib.patch
deleted file mode 100644
index c187dcd4d1d9..000000000000
--- a/dev-python/PyQt4/files/PyQt4-4.6.1-configure-multilib.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- PyQt-x11-gpl-4.6.1~orig/configure.py 2009-11-04 22:28:05.000000000 +0100
-+++ PyQt-x11-gpl-4.6.1/configure.py 2009-11-04 23:10:01.000000000 +0100
-@@ -854,8 +854,8 @@
- # version.
- link = "-framework Python"
- elif ("--enable-shared" in ducfg.get("CONFIG_ARGS", "") and
-- glob.glob("%s/lib/libpython%d.%d*" % (ducfg["exec_prefix"], py_major, py_minor))):
-- lib_dir_flag = quote("-L%s/lib" % ducfg["exec_prefix"])
-+ glob.glob("%s/libpython%d.%d*" % (ducfg["LIBDIR"], py_major, py_minor))):
-+ lib_dir_flag = quote("-L%s" % ducfg["LIBDIR"])
- link = "%s -lpython%d.%d" % (lib_dir_flag, py_major, py_minor)
- else:
- sipconfig.inform("Qt Designer plugin disabled because Python library is static")
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index d55a95328410..8e20107ce529 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.217 2012/07/08 18:25:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.218 2012/07/09 13:30:05 pesa Exp $
+
+ 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -sip-4.11.2.ebuild:
+ Remove old.
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> sip-4.13.2-r1.ebuild:
alpha/ia64/sparc stable wrt #412929
diff --git a/dev-python/sip/sip-4.11.2.ebuild b/dev-python/sip/sip-4.11.2.ebuild
deleted file mode 100644
index dcd52e12464e..000000000000
--- a/dev-python/sip/sip-4.11.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.11.2.ebuild,v 1.10 2012/02/20 10:13:40 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-inherit eutils python toolchain-funcs
-
-MY_P="${P/_pre/-snapshot-}"
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- --bindir="${EPREFIX}/usr/bin"
- --incdir="${EPREFIX}$(python_get_includedir)"
- --destdir="${EPREFIX}$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- $(use debug && echo --debug)
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- CFLAGS="${CFLAGS}"
- CXXFLAGS="${CXXFLAGS}"
- LFLAGS="${LDFLAGS}"
- STRIP=":")
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS || die "dodoc failed"
-
- if use doc; then
- dohtml -r doc/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn "When updating dev-python/sip, you usually need to rebuild packages, which depend on dev-python/sip,"
- ewarn "such as dev-python/PyQt4 and dev-python/qscintilla-python. If you have app-portage/gentoolkit"
- ewarn "installed, you can find these packages with \`equery d dev-python/sip dev-python/PyQt4\`."
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}