summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-07-04 01:05:48 +0000
committerJoshua Brindle <method@gentoo.org>2003-07-04 01:05:48 +0000
commit5357cc60ae75750495785f4bab2041d0904ec7af (patch)
tree7ef078e884f69344ff92666db4bb557fb56378a1 /dev-python
parentinitial commit (diff)
downloadhistorical-5357cc60ae75750495785f4bab2041d0904ec7af.tar.gz
historical-5357cc60ae75750495785f4bab2041d0904ec7af.tar.bz2
historical-5357cc60ae75750495785f4bab2041d0904ec7af.zip
initial commit
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-selinux/Manifest5
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-1.01
-rw-r--r--dev-python/python-selinux/metadata.xml11
-rw-r--r--dev-python/python-selinux/python-selinux-1.0.ebuild25
4 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index 59f448d95c97..f71f01816788 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,3 +1,4 @@
-MD5 cfcf0531681c016a3e6a1439f637ffea python-selinux-1.0.ebuild 583
-MD5 3c854e24c135383faef5f0fe74b62632 ChangeLog 310
+MD5 6b1aac989d314c2d50a4e9120e7a99e2 python-selinux-1.0.ebuild 697
+MD5 a3963e941c121f92f339ceaeecead336 ChangeLog 408
+MD5 f182ab46e74041b1e72cc2f0e31d09d7 metadata.xml 418
MD5 41ce3631984a8e2bf2dc1a9ea66a7315 files/digest-python-selinux-1.0 69
diff --git a/dev-python/python-selinux/files/digest-python-selinux-1.0 b/dev-python/python-selinux/files/digest-python-selinux-1.0
new file mode 100644
index 000000000000..942de1aeb32b
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-1.0
@@ -0,0 +1 @@
+MD5 eaf3f08ad6067ad8fdcf1853e326afce python-selinux-1.0.tar.bz2 5087
diff --git a/dev-python/python-selinux/metadata.xml b/dev-python/python-selinux/metadata.xml
new file mode 100644
index 000000000000..c08f4803b57f
--- /dev/null
+++ b/dev-python/python-selinux/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>hardened</herd>
+<maintainer>
+ <email>pebenito@gentoo.org</email>
+ <name>Chris PeBenito</name>
+ <description>Primary Maintainer</description>
+</maintainer>
+<longdescription>Python bindings for sid related libsecure fuctions, donated by torbenh@freenode</longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-selinux/python-selinux-1.0.ebuild b/dev-python/python-selinux/python-selinux-1.0.ebuild
new file mode 100644
index 000000000000..bbfb4e7f58e0
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-1.0.ebuild,v 1.1 2003/07/04 01:05:44 method Exp $
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://selinux.dev.gentoo.org/python"
+SRC_URI="http://selinux.dev.gentoo.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="selinux"
+
+DEPEND="sys-apps/selinux-small"
+RDEPEND="sys-apps/selinux-small"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ gcc -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lsecure
+}
+
+src_install() {
+ cp selinux.so /usr/lib/python2.2/site-packages
+}