summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-09-01 11:49:39 +0000
committerTorsten Veller <tove@gentoo.org>2011-09-01 11:49:39 +0000
commit8e5ff21194caf6743ff8cb35c4078ae78bd03897 (patch)
treec0e019124a31be3d0eabc6f9867fdb7393295c79 /dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild
parentVersion bump to release 91: includes my changes and a couple of security-sens... (diff)
downloadhistorical-8e5ff21194caf6743ff8cb35c4078ae78bd03897.tar.gz
historical-8e5ff21194caf6743ff8cb35c4078ae78bd03897.tar.bz2
historical-8e5ff21194caf6743ff8cb35c4078ae78bd03897.zip
Change version scheme
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild')
-rw-r--r--dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild b/dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild
new file mode 100644
index 000000000000..6275206f112b
--- /dev/null
+++ b/dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Context-Preserve/Context-Preserve-0.10.0.ebuild,v 1.1 2011/09/01 10:42:47 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JROCKWAY
+MODULE_VERSION=0.01
+inherit perl-module
+
+DESCRIPTION="Pass chained return values from subs, modifying their values, without losing context."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-use-ok
+ )"
+
+SRC_TEST="do"