summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-28 08:44:44 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-28 08:44:44 +0000
commit81cdf7b88cb4961653c6b146dba47076477dca19 (patch)
treed344616c5d7c47266da3a7ccac248965025fe737 /dev-libs/atk/atk-1.0.2.ebuild
parentRobustness tweaks. (diff)
downloadhistorical-81cdf7b88cb4961653c6b146dba47076477dca19.tar.gz
historical-81cdf7b88cb4961653c6b146dba47076477dca19.tar.bz2
historical-81cdf7b88cb4961653c6b146dba47076477dca19.zip
new gtk+ and glib related packages
Diffstat (limited to 'dev-libs/atk/atk-1.0.2.ebuild')
-rw-r--r--dev-libs/atk/atk-1.0.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/atk/atk-1.0.2.ebuild b/dev-libs/atk/atk-1.0.2.ebuild
new file mode 100644
index 000000000000..09ffed42ac88
--- /dev/null
+++ b/dev-libs/atk/atk-1.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Spider <spider.gentoo@darkmere.wanfear.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.2.ebuild,v 1.1 2002/05/28 08:44:43 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+SLOT="1"
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Accessibility Toolkit"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.3"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+# since no other of gtk pango and glib use this, remove it. its not recommended either
+# libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug || die
+
+## Since glib fails with debug, we debug here too
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
+}
+