summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-05-31 13:24:52 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-05-31 13:24:52 +0000
commit63c079786abb434b102b778f98f3c3e1d97686a5 (patch)
treec4dc7463cd965db2a185b0d702c02af90f513e33 /app-i18n/ibus-table
parentVersion bumped. Removed old versions. (diff)
downloadhistorical-63c079786abb434b102b778f98f3c3e1d97686a5.tar.gz
historical-63c079786abb434b102b778f98f3c3e1d97686a5.tar.bz2
historical-63c079786abb434b102b778f98f3c3e1d97686a5.zip
Version bumped.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/ChangeLog12
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild47
2 files changed, 58 insertions, 1 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index d3ef795b10b5..c7e8b47368c2 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.10 2009/05/07 23:47:54 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.11 2009/05/31 13:24:17 matsuu Exp $
+
+ 31 May 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.1.0.20090527.ebuild:
+ Version bumped.
+
+*ibus-table-1.1.0.20090527 (31 May 2009)
+
+ 31 May 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.1.0.20090527.ebuild:
+ Version bumped.
*ibus-table-1.1.0.20090505 (07 May 2009)
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild
new file mode 100644
index 000000000000..73403ce1fbee
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090527.ebuild,v 1.1 2009/05/31 13:24:17 matsuu Exp $
+
+EAPI="2"
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal nls"
+
+RDEPEND=">=app-i18n/ibus-1.1
+ >=dev-lang/python-2.5[sqlite]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable !minimal additional) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}