summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-08 12:01:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-08 12:01:39 +0000
commit50bb63380acaca38aa13b645a30f8105aae01b2f (patch)
tree73f3b30cd6d2a5d15726da298e628283856a864f /app-forensics/afflib
parentStable for ppc. (diff)
downloadhistorical-50bb63380acaca38aa13b645a30f8105aae01b2f.tar.gz
historical-50bb63380acaca38aa13b645a30f8105aae01b2f.tar.bz2
historical-50bb63380acaca38aa13b645a30f8105aae01b2f.zip
Bump
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/ChangeLog7
-rw-r--r--app-forensics/afflib/afflib-3.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index 8255e9ae95ed..2cec045e52d7 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.6 2009/08/06 14:32:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.7 2009/11/08 12:01:39 patrick Exp $
+
+*afflib-3.5.2 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +afflib-3.5.2.ebuild:
+ Bump
06 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> afflib-3.3.4.ebuild,
+files/afflib-3.3.4-glibc-2.10.patch:
diff --git a/app-forensics/afflib/afflib-3.5.2.ebuild b/app-forensics/afflib/afflib-3.5.2.ebuild
new file mode 100644
index 000000000000..962b0ca05ea7
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.5.2.ebuild,v 1.1 2009/11/08 12:01:39 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}