summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2002-12-12 13:32:17 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2002-12-12 13:32:17 +0000
commitffe86a11cb030c8abdfff41731f838e29dee666d (patch)
treedfcd0ba12da3ebdeb28d21af4a3752e60fe345ee /app-emulation
parentinitial ebuild + digest + changeLog (diff)
downloadhistorical-ffe86a11cb030c8abdfff41731f838e29dee666d.tar.gz
historical-ffe86a11cb030c8abdfff41731f838e29dee666d.tar.bz2
historical-ffe86a11cb030c8abdfff41731f838e29dee666d.zip
initial ebuild+digest+ChangeLog bug #4395
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/game-launcher/ChangeLog5
-rw-r--r--app-emulation/game-launcher/files/digest-game-launcher-0.9.81
-rw-r--r--app-emulation/game-launcher/game-launcher-0.9.8.ebuild63
3 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/game-launcher/ChangeLog b/app-emulation/game-launcher/ChangeLog
new file mode 100644
index 000000000000..c3ef262d9b1c
--- /dev/null
+++ b/app-emulation/game-launcher/ChangeLog
@@ -0,0 +1,5 @@
+# ChangeLog for game-launcher
+
+* game-launcher-0.9.8 (27 Oct 2002)
+ Thomas Raschbacher <lordvan@lordvan.com>: added ebuild
+ WARNING: is a security-hole cuz parts of it are(and have to be) world-writeable!!!! \ No newline at end of file
diff --git a/app-emulation/game-launcher/files/digest-game-launcher-0.9.8 b/app-emulation/game-launcher/files/digest-game-launcher-0.9.8
new file mode 100644
index 000000000000..e8ce54296631
--- /dev/null
+++ b/app-emulation/game-launcher/files/digest-game-launcher-0.9.8
@@ -0,0 +1 @@
+MD5 773dcd3b8f38574ec8117986031c2a65 gl098s.zip 357961
diff --git a/app-emulation/game-launcher/game-launcher-0.9.8.ebuild b/app-emulation/game-launcher/game-launcher-0.9.8.ebuild
new file mode 100644
index 000000000000..fb81e99cca88
--- /dev/null
+++ b/app-emulation/game-launcher/game-launcher-0.9.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.1 2002/12/12 13:32:17 lordvan Exp $
+
+DESCRIPTION="Game Launcher is a cross platform, universal front end for emulators.It has been known to work with MAME, Nesticle, RockNES, zSNES, snes9x, Callus, Stella, z26 and Genecyst."
+HOMEPAGE="http://www.dribin.org/dave/game_launcher/"
+SRC_URI="mirror://sourceforge/glaunch/gl098s.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=media-libs/allegro-4.0.0
+ >=media-libs/loadpng-0.11
+ >=media-libs/allegromp3-2.0.2
+ >=media-libs/allegttf-2.0
+ >=media-libs/libpng-1.2.4
+ >=sys-libs/zlib-1.1.4
+ >=app-arch/unzip-5.50
+ >=app-text/recode-3.6"
+
+RDEPEND=">=media-libs/allegro-4.0.0
+ >=media-libs/loadpng-0.11
+ >=media-libs/allegromp3-2.0.2
+ >=media-libs/allegttf-2.0
+ >=media-libs/libpng-1.2.4
+ >=sys-libs/zlib-1.1.4"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+S="${WORKDIR}/glaunch"
+
+src_compile() {
+ cd ${S}
+ # got to recode this cuz gcc complains about CF+LF after a '\'
+ recode /CR mamescan/main.cc \
+ mamescan/scanner.cc \
+ mamescan/gamelist.cc \
+ model/emumgr.cc \
+ control/emumenu.cc \
+ control/launcher.cc \
+ control/bgctrl.cc
+ # set TARGET (maybe set compile options here later too)
+ mv common.mk common.mk_orig
+ sed s/'TARGET\(.*\)= MINGW'/'#TARGET\1= MINGW'/ common.mk_orig | sed s/'#TARGET\(.*\)= UNIX'/'TARGET\1= UNIX'/ > common.mk
+ emake || die
+
+}
+
+src_install() {
+ dodir /opt/${P}
+# cp glaunch _gl32 glaunch.dat glaunch.cfg slicker.ttf mamescan.exe ${D}/opt/${P}
+ cp -r ${S}/* ${D}/opt/${P} # doinst can't do recursive
+}
+
+pkg_postinst() {
+ echo
+ einfo "WARNING: Some files in /opt/${P} are world writeable!!!"
+ einfo "Because of the design that can't be changed easily."
+ einfo "You can add a new group and then change the permissions."
+ einfo "Members of that group then can run it."
+ echo
+} \ No newline at end of file