summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-0.28.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index 191b60eefb4d..555502abc41f 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1,2 +1,3 @@
DIST vertico-0.26.tar.gz 43410 BLAKE2B d8967dad143066dcf288d9cb103d9a66732262598867f4d7184e6c2b1c7fd98629b0e0fe012f7c9960a3e194656507ff3150bcc372258b0c45c839aae2506ae6 SHA512 a4246169db6f8f8e2f65e8b8f1c3c5a52e29d226b92cf30ff968a44f9293e4c6dceaf567516066e3d1e5212edf7c4a25825719072d3c2bbffca9967a500e7605
DIST vertico-0.27.tar.gz 43417 BLAKE2B be9fcd53c836e16f6ee3380ed8f727fbc62153a87a759dee7091b959f3ad0a940a6c1fe176a2073db153ae855b42a64ee92f57e7f3be4538c2f8a13606443d06 SHA512 cce90065473cf8440567b591544bf74af71752e476b667d7bc7d77bb83c8d43e38f2170f5e66f4723dfe29e6228d4933be2cb0d899cb8b56843a6a1ecb07f6a3
+DIST vertico-0.28.tar.gz 43472 BLAKE2B 4c2771104960ee95ac7dffebecdf30ddfcc42bb91377dbbf27f245e9f93eb392dfa16a9fdd45f34ef739b4f9364cdb3d5c9dca9dd2a111a0008b726bc31df117 SHA512 3844f16184056210cadc755e52d5886c9c6ed0b00278d5c1b0d30e2d13dd8b63215026305e62d69873aaea720aadaeb772b29161d98d2e080b302565bd1f1d4a
diff --git a/app-emacs/vertico/vertico-0.28.ebuild b/app-emacs/vertico/vertico-0.28.ebuild
new file mode 100644
index 000000000000..eec14ff439d5
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.28.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}