aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/openbabel-python/openbabel-python-2.2.2.ebuild')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.2.2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.2.2.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.2.2.ebuild
index b1a531822..2ba48ecf6 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.2.2.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -26,11 +26,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/openbabel-${PV}"
-src_compile() {
+src_configure() {
econf \
$(use_enable swig maintainer-mode) \
--enable-static \
|| die "econf failed"
+}
+
+src_compile() {
if use swig ; then
cd "${S}/scripts"
emake -W openbabel-python.i python/openbabel_python.cpp \
@@ -47,4 +50,3 @@ src_install() {
dohtml *.html
dodoc README
}
-