aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/openbabel-perl/openbabel-perl-2.2.3.ebuild')
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-2.2.3.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-2.2.3.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-2.2.3.ebuild
deleted file mode 100644
index 45ada92ac..000000000
--- a/sci-chemistry/openbabel-perl/openbabel-perl-2.2.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils perl-module
-
-DESCRIPTION="Perl bindings for OpenBabel"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openbabel/openbabel-${PV}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="swig"
-
-RDEPEND="
- dev-lang/perl
- ~sci-chemistry/openbabel-${PV}"
-DEPEND="${RDEPEND}
- swig? ( dev-lang/swig )"
-
-src_unpack() {
- unpack ${A}
- S="${WORKDIR}/openbabel-${PV}"
- cd "${S}"
-
- econf \
- $(use_enable swig maintainer-mode) \
- --enable-static \
- || die "econf failed"
- S="${S}/scripts"
- cd "${S}"
- if use swig ; then
- emake -W openbabel-perl.i perl/openbabel_perl.cpp \
- || die "Failed to make SWIG perl bindings"
- fi
- S="${S}/perl"
- cd "${S}"
- epatch "${FILESDIR}/${P}-makefile.patch" \
- || die "Failed to apply ${P}-makefile.patch"
-}
-
-src_compile() {
- perl-module_src_prep
- perl-module_src_compile
-}
-
-src_test() {
- emake test || die "make test failed"
-}
-
-src_install() {
- perl-module_src_install
-}
-
-pkg_preinst() {
- perl-module_pkg_preinst
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
-}
-
-pkg_prerm() {
- perl-module_pkg_prerm
-}
-
-pkg_postrm() {
- perl-module_pkg_postrm
-}