aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/archspec/Manifest1
-rw-r--r--dev-python/archspec/archspec-0.2.5.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/archspec/Manifest b/dev-python/archspec/Manifest
index c3dd31924..3262809c8 100644
--- a/dev-python/archspec/Manifest
+++ b/dev-python/archspec/Manifest
@@ -1 +1,2 @@
DIST archspec-0.2.4.tar.gz 52834 BLAKE2B cb8b9fce38b44783a361568667d5690e5c5169149ebdd3d4bf0943c056a4c8c9e2cb3a13a0b9b39e07f9b907b8f5ec4d1552a925d2e9bee76acf858d1a3f3ed5 SHA512 40a83854982670cb5cf77aab496198b3c6723a5cc386f05b8a020d9e94834d4109436cade9b9c89abac909c17b912f00aab8df2d6b05251c0afba9cee1932a62
+DIST archspec-0.2.5.tar.gz 53848 BLAKE2B 429c39494d046b3e95a67e58b4f165445ff44a4615f02b1c655a1f57331a8ffae7342b360b1a5560fd99271682b826d0c49710e33e2c93f9e1204f1fe1a8f581 SHA512 583b3cd7442d2392516ddd4fcaf363ff70ef9e5ee4c72089d21f4ea3e7dfff72e22b24a475ab5c00e9baf7789df65a272b894e241bb5ae7c91cf1e3a71bb83bb
diff --git a/dev-python/archspec/archspec-0.2.5.ebuild b/dev-python/archspec/archspec-0.2.5.ebuild
new file mode 100644
index 000000000..002a57ba1
--- /dev/null
+++ b/dev-python/archspec/archspec-0.2.5.ebuild
@@ -0,0 +1,21 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 pypi
+
+DESCRIPTION="Labels for various aspects of a system architecture like CPU, etc."
+HOMEPAGE="https://archspec.readthedocs.io/en/latest/index.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest