aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-04-21 03:21:28 -0400
committerHorea Christian <chr@chymera.eu>2023-04-21 03:21:28 -0400
commit04e5014d1c939e1f9bccb6503cdc6ad1aee9cc3c (patch)
tree8759f9ee4fee902eb479b2d4bd3e77bc86d36ac8 /sci-electronics
parentsci-biology/pbbam: add github upstream metadata (diff)
downloadsci-04e5014d1c939e1f9bccb6503cdc6ad1aee9cc3c.tar.gz
sci-04e5014d1c939e1f9bccb6503cdc6ad1aee9cc3c.tar.bz2
sci-04e5014d1c939e1f9bccb6503cdc6ad1aee9cc3c.zip
sci-electronics/mpremote: new package, add 0.4.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/mpremote/Manifest1
-rw-r--r--sci-electronics/mpremote/metadata.xml20
-rw-r--r--sci-electronics/mpremote/mpremote-0.4.0.ebuild28
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-electronics/mpremote/Manifest b/sci-electronics/mpremote/Manifest
new file mode 100644
index 000000000..a23fad530
--- /dev/null
+++ b/sci-electronics/mpremote/Manifest
@@ -0,0 +1 @@
+DIST mpremote-0.4.0.tar.gz 27266 BLAKE2B b31b6184d0f4fc5c525ea7d5d8d2722404e9ce82ce143ea9a14b8bdef28af3260514dd25ec756a0ac2507d5b206fa9d07ce67bd2228b1568d9495c9082bdace8 SHA512 580f0286d8973a93105a04c681428f798e0d72b4b75debbc43f8e49ea7a81da849987aeab795baff66c9cf40607fde27fb54b7b32ab311ae5e9fb3b8f8f976fc
diff --git a/sci-electronics/mpremote/metadata.xml b/sci-electronics/mpremote/metadata.xml
new file mode 100644
index 000000000..820065154
--- /dev/null
+++ b/sci-electronics/mpremote/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-electronics@gentoo.org</email>
+ <name>Gentoo Electronics Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <longdescription lang="en">
+ This CLI tool provides an integrated set of utilities to remotely interact with
+ and automate a MicroPython device over a serial connection.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">micropython/micropython</remote-id>
+ <remote-id type="pypi">mpremote</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-electronics/mpremote/mpremote-0.4.0.ebuild b/sci-electronics/mpremote/mpremote-0.4.0.ebuild
new file mode 100644
index 000000000..80056b01e
--- /dev/null
+++ b/sci-electronics/mpremote/mpremote-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+# Next release will move to hatchling:
+# https://github.com/micropython/micropython/pull/10645
+#DISTUTILS_USE_PEP517=hatchling
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MicroPython remote control"
+HOMEPAGE="https://github.com/micropython/micropython/tree/master/tools/mpremote"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+"
+
+# The package might not have a test suite:
+# https://github.com/orgs/micropython/discussions/11308
+#distutils_enable_tests pytest