aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-22 08:24:03 +0200
committerJustin Lecher <jlec@gentoo.org>2014-07-22 08:24:03 +0200
commit2d31cad7dc40c77ad0c47d90e2b5f9b78c107b9b (patch)
tree9e589f708648a2789c5aa189c8c1d88805230638 /sci-chemistry/redcat
parentsci-chemistry/pales-bin: Drop -bin suffix from executable (diff)
downloadsci-2d31cad7dc40c77ad0c47d90e2b5f9b78c107b9b.tar.gz
sci-2d31cad7dc40c77ad0c47d90e2b5f9b78c107b9b.tar.bz2
sci-2d31cad7dc40c77ad0c47d90e2b5f9b78c107b9b.zip
sci-chemistry/redcat: New package written by me
Package-Manager: portage-2.2.10
Diffstat (limited to 'sci-chemistry/redcat')
-rw-r--r--sci-chemistry/redcat/ChangeLog14
-rw-r--r--sci-chemistry/redcat/Manifest1
-rw-r--r--sci-chemistry/redcat/files/CMakeLists.txt13
-rw-r--r--sci-chemistry/redcat/metadata.xml8
-rw-r--r--sci-chemistry/redcat/redcat-3.ebuild62
5 files changed, 98 insertions, 0 deletions
diff --git a/sci-chemistry/redcat/ChangeLog b/sci-chemistry/redcat/ChangeLog
new file mode 100644
index 000000000..665093eb0
--- /dev/null
+++ b/sci-chemistry/redcat/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sci-chemistry/redcat
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 22 Jul 2014; Justin Lecher <jlec@gentoo.org> +redcat-3.ebuild,
+ +files/CMakeLists.txt, +metadata.xml:
+ New package written by me
+
+*redcat-3 (17 Jul 2014)
+
+ 17 Jul 2014; Justin Lecher <jlec@gentoo.org> +redcat-3.ebuild,
+ +files/CMakeLists.txt, +.listing, +metadata.xml:
+ New package written by me
+
diff --git a/sci-chemistry/redcat/Manifest b/sci-chemistry/redcat/Manifest
new file mode 100644
index 000000000..9d858143f
--- /dev/null
+++ b/sci-chemistry/redcat/Manifest
@@ -0,0 +1 @@
+DIST Redcat.3.tar.gz 6151543 SHA256 72194f5e7ec0f033a6ececdda7337d4c1992cf76a0ca193561f10ac99a91d7c3 SHA512 a7635ab43a0644f02c534601ace66d1765d78a9715e4064917422f664400c4b5a816c1662c2e36c5bb8dc630b5693c75b26547c4754b54341f12a5d4eadda782 WHIRLPOOL 400567cc2920680b0ecae213f822e3e42231f1a1abff365f8763ca0fbc0bd9cc0f59b0478c17cb582c207227559e7f5ed2589320499891d376e710fba95cff81
diff --git a/sci-chemistry/redcat/files/CMakeLists.txt b/sci-chemistry/redcat/files/CMakeLists.txt
new file mode 100644
index 000000000..d8896a93a
--- /dev/null
+++ b/sci-chemistry/redcat/files/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.8)
+project (Redcat)
+
+find_package(Eigen3 REQUIRED)
+
+include_directories (${Redcat_SOURCE_DIR}/src)
+include_directories (${EIGEN_INCLUDE_DIR})
+
+add_executable (Redcat src/main.cpp src/Redcat.cpp src/tensor.cpp src/matrix.cpp src/SVDiface.cpp)
+add_executable (Dynamic src/Dynamic.cpp)
+
+install (TARGETS Redcat Dynamic DESTINATION bin)
+
diff --git a/sci-chemistry/redcat/metadata.xml b/sci-chemistry/redcat/metadata.xml
new file mode 100644
index 000000000..ae9ec7c5f
--- /dev/null
+++ b/sci-chemistry/redcat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/redcat/redcat-3.ebuild b/sci-chemistry/redcat/redcat-3.ebuild
new file mode 100644
index 000000000..dfa1ecf5f
--- /dev/null
+++ b/sci-chemistry/redcat/redcat-3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils java-utils-2
+
+DESCRIPTION="Analysis of residual dipolar couplings (RDCs) for structure validation and elucidation"
+HOMEPAGE="http://ifestos.cse.sc.edu/software.php"
+SRC_URI="http://ifestos.cse.sc.edu/downloads.php?get=Redcat.${PV}.tar.gz -> Redcat.${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-lang/tcl
+ dev-tcltk/bwidget
+ virtual/jdk:1.7
+ "
+DEPEND="${RDEPEND}
+ virtual/jre:1.7
+"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"/Redcat
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "http://ifestos.cse.sc.edu/downloads.php"
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+ sed \
+ -e '/BWidget/s:1.9.4:1.9.7:g' \
+ -i scripts/REDCAT.tcl || die
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ java-pkg_dojar XplorGUI/XplorGUI.jar
+ java-pkg_dolauncher XplorGUI --jar XplorGUI.jar
+
+ dodoc Misc/REDCATManual.odt
+ docompress -x /usr/share/doc/${PF}/REDCATManual.odt
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*
+
+ dosym ../libexec/${PN}/REDCAT.tcl /usr/bin/REDCAT.tcl
+ dosym ../libexec/${PN}/MakeRedcat.tcl /usr/bin/MakeRedcat.tcl
+
+ echo "${EPREFIX}/usr/share/redcat/" > conf/${PN}.conf
+ insinto /usr/share/redcat/
+ doins -r conf/${PN}.conf vmd data
+}