aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinis Danne <rei4dan@gmail.com>2009-02-10 23:40:50 +0200
committerReinis Danne <rei4dan@gmail.com>2009-02-21 01:26:30 +0200
commitce2b954019ac1005c30b25eda994e17dcdd7fe63 (patch)
tree3f826c09c638b4a4fe054e985d30a65a1ba9f789 /sci-chemistry/openbabel-python
parentNew package sci-chemistry/openbabel-perl, #212212 (diff)
downloadsci-ce2b954019ac1005c30b25eda994e17dcdd7fe63.tar.gz
sci-ce2b954019ac1005c30b25eda994e17dcdd7fe63.tar.bz2
sci-ce2b954019ac1005c30b25eda994e17dcdd7fe63.zip
New package sci-chemistry/openbabel-python, #212212
openbabel-python-2.2.0.ebuild and metadata.xml.
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog10
-rw-r--r--sci-chemistry/openbabel-python/Manifest4
-rw-r--r--sci-chemistry/openbabel-python/metadata.xml15
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.2.0.ebuild70
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
new file mode 100644
index 000000000..47d533978
--- /dev/null
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/openbabel-python
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*openbabel-python-2.2.0 (10 Feb 2009)
+
+ 10 Feb 2009; Reinis Danne <rei4dan@gmail.com> +metadata.xml,
+ +openbabel-python-2.2.0.ebuild:
+ New package sci-chemistry/openbabel-python, #212212
+
diff --git a/sci-chemistry/openbabel-python/Manifest b/sci-chemistry/openbabel-python/Manifest
new file mode 100644
index 000000000..ab8813cc9
--- /dev/null
+++ b/sci-chemistry/openbabel-python/Manifest
@@ -0,0 +1,4 @@
+DIST openbabel-2.2.0.tar.gz 6127264 RMD160 ade8e65ab37278d9af3ff1b9cfb115437f52e0ea SHA1 5fdc084fb744d5dae4cd9ddbd52fe1f0c56c973b SHA256 a898b79336c7372c901bcc7e5f83db7b8e79f8e864be6a262f515b3e088bc607
+EBUILD openbabel-python-2.2.0.ebuild 1626 RMD160 c2635d28ff44ea071d6c3d007fb1134c39bbe489 SHA1 4d1b87e5fd68ff0a54627fa769b668cb983982d4 SHA256 4f387ac3a068287e913660b84ae4f421d176138aeb5e806aaa498221ac826e41
+MISC ChangeLog 322 RMD160 aaa7a6a591ef2a1dddc8bf99a2c69530d6277058 SHA1 53691e78622857d7dea45f530902e038e6df1ce1 SHA256 1a32395c0e983247a81b180f08687deafbacf8be1d0ba0c7bbbda687b472c551
+MISC metadata.xml 627 RMD160 2eed792ed60ef1e4fe0aba88690f1fc4ff93b3e5 SHA1 d1e9cc0888dfedadb394def1835b272d11d91b38 SHA256 83b3a75fd868e56866941cba2671a75decc1e099e22709b3c6e799767f1e7253
diff --git a/sci-chemistry/openbabel-python/metadata.xml b/sci-chemistry/openbabel-python/metadata.xml
new file mode 100644
index 000000000..7dd11d8d7
--- /dev/null
+++ b/sci-chemistry/openbabel-python/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<longdescription>
+OpenBabel is a chemical toolbox designed to speak the many languages of
+chemical data. It's an open, collaborative project allowing anyone to
+search, convert, analyze, or store data from molecular modeling, chemistry,
+solid-state materials, biochemistry, or related areas. This package enables
+to access OpenBabel library from Python programs.
+</longdescription>
+<use>
+<flag name='swig'>Enable SWIG language binding regeneration</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.2.0.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.2.0.ebuild
new file mode 100644
index 000000000..b46da3207
--- /dev/null
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Python bindings for OpenBabel (including Pybel)"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/openbabel-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="swig"
+
+RDEPEND="~sci-chemistry/openbabel-2.2.0
+ dev-lang/python"
+
+DEPEND="${RDEPEND}
+ swig? ( >=dev-lang/swig-1.3.29 )"
+
+src_unpack() {
+ unpack ${A}
+ S="${WORKDIR}/openbabel-${PV}"
+ cd "${S}"
+
+ local myconf=""
+ if use swig ; then
+ if ! built_with_use dev-lang/swig python ; then
+ echo
+ eerror "To be able to build openbabel-python with swig use"
+ eerror "dev-lang/swig has to be merged with python enabled."
+ eerror "Please, re-emerge dev-lang/swig with USE=\"python\"."
+ die "dev-lang/swig has been built without python support"
+ else
+ myconf="--enable-maintainer-mode"
+ fi
+ fi
+ econf \
+ ${myconf} \
+ --enable-static \
+ || die "econf failed"
+ S="${S}/scripts"
+ cd "${S}"
+ if use swig ; then
+ emake python/openbabel_python.cpp \
+ || die "Failed to make SWIG python bindings"
+ fi
+ S="${S}/python"
+ cd "${S}"
+}
+
+src_compile() {
+ python ./setup.py build || die "python setup build failed"
+}
+
+src_install() {
+ python ./setup.py install --root="${D}" --optimize=1 \
+ || die "python setup install failed"
+ dohtml *.html
+ dodoc README
+}
+
+pkg_postinst() {
+ echo
+ elog "To be able to fully use Pybel you might need to install additional"
+ elog "libraries:"
+ elog "OASA - part of BKChem package"
+ elog "PIL - dev-python/imaging"
+}