aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <marcus@cryos.org>2009-03-15 12:30:52 -0400
committerMarcus D. Hanwell <marcus@cryos.org>2009-03-15 12:30:52 -0400
commit7c96118b00712adb8e51d734fa31a737e6e77b29 (patch)
tree58cb2f35e23af386afea38c24b45eed11daf2b32 /sci-chemistry/openbabel-python
parentsci-chemistry/pymol-plugins-cealign added (diff)
downloadsci-7c96118b00712adb8e51d734fa31a737e6e77b29.tar.gz
sci-7c96118b00712adb8e51d734fa31a737e6e77b29.tar.bz2
sci-7c96118b00712adb8e51d734fa31a737e6e77b29.zip
Made some changes to the ebuild, do not configure in the src_unpack phase.
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog4
-rw-r--r--sci-chemistry/openbabel-python/Manifest4
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.2.1.ebuild15
3 files changed, 10 insertions, 13 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index 476549e13..e5dd0207e 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Mar 2009; Marcus D. Hanwell <cryos@gentoo.org>
+ sci-chemistry/openbabel-python/openbabel-python-2.2.1.ebuild:
+ Made some changes to the ebuild, do not configure in the src_unpack phase.
+
*openbabel-python-2.2.1 (03 Mar 2009)
03 Mar 2009; Reinis Danne <rei4dan@gmail.com>
diff --git a/sci-chemistry/openbabel-python/Manifest b/sci-chemistry/openbabel-python/Manifest
index fc60e7ead..82aab895e 100644
--- a/sci-chemistry/openbabel-python/Manifest
+++ b/sci-chemistry/openbabel-python/Manifest
@@ -1,6 +1,6 @@
DIST openbabel-2.2.0.tar.gz 6127264 RMD160 ade8e65ab37278d9af3ff1b9cfb115437f52e0ea SHA1 5fdc084fb744d5dae4cd9ddbd52fe1f0c56c973b SHA256 a898b79336c7372c901bcc7e5f83db7b8e79f8e864be6a262f515b3e088bc607
DIST openbabel-2.2.1.tar.gz 6507473 RMD160 47c6afecc1a7c847052dcb8570eee89a52416586 SHA1 736fc5b69851d72b58545c5ba8c2bbd361d64e46 SHA256 822345d70778de1d2d9afe65a659f1719b8ca300066fb1fa2f473bc97c457e80
EBUILD openbabel-python-2.2.0.ebuild 1109 RMD160 0fb55f28516e7b971ea8bf10e187303113951c79 SHA1 31d0f5adcdcdb98068b85d7819fae8a1fbbfbf50 SHA256 5a713877cd0ec0608cb4d638ff35872c985f3fad87c55d40eaaa646112c03875
-EBUILD openbabel-python-2.2.1.ebuild 1093 RMD160 ba1cfecdcc0a3494837650b26124cf0c77a92113 SHA1 f054ce6d37624c7a58418bb83b9b72639d94e432 SHA256 c6e8666f0321bb2763a790a2691f7dee5fdfb3dcac8ff2d36d36039d57c83094
-MISC ChangeLog 725 RMD160 716117dd5e88385a530f385e2e971e95b0ab8fdc SHA1 416a5ff7d4fbd5067ae6bc055558f743a1d4a0b1 SHA256 d3016570c407e9aa66f03d68ed8019e9582318fc3e86f9722baddfc9a04b79dd
+EBUILD openbabel-python-2.2.1.ebuild 1039 RMD160 857351f41b46169fe69a4ef9fb8598ea6d1bcddf SHA1 9bd4f6af957bbc8efb404277566474c2658dd856 SHA256 753f60e68457f0d7d4c2ac78747c70e7bee1283542e2b35ebe030746ab972d35
+MISC ChangeLog 919 RMD160 ba6faf20c3af0e498a67817e28ea168a70ebcb83 SHA1 c44b8250b9c4ed999dd15af8ef3f1f1a6a96c5aa SHA256 1a7ccd5a49652edb8600bbde165962316ba6a623e0bb664662fc32d29169813d
MISC metadata.xml 627 RMD160 2eed792ed60ef1e4fe0aba88690f1fc4ff93b3e5 SHA1 d1e9cc0888dfedadb394def1835b272d11d91b38 SHA256 83b3a75fd868e56866941cba2671a75decc1e099e22709b3c6e799767f1e7253
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.2.1.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.2.1.ebuild
index 0e434ad18..b751493dd 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.2.1.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.2.1.ebuild
@@ -21,26 +21,19 @@ RDEPEND="~sci-chemistry/openbabel-${PV}
DEPEND="${RDEPEND}
swig? ( >=dev-lang/swig-1.3.38 )"
-src_unpack() {
- unpack ${A}
- S="${WORKDIR}/openbabel-${PV}"
- cd "${S}"
+S="${WORKDIR}/openbabel-${PV}"
+src_compile() {
econf \
$(use_enable swig maintainer-mode) \
--enable-static \
|| die "econf failed"
- S="${S}/scripts"
- cd "${S}"
if use swig ; then
+ cd "${S}/scripts"
emake -W openbabel-python.i python/openbabel_python.cpp \
|| die "Failed to make SWIG python bindings"
fi
- S="${S}/python"
- cd "${S}"
-}
-
-src_compile() {
+ cd "${S}/scripts/python"
python ./setup.py build || die "python setup build failed"
}