summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-04-03 08:14:46 +0200
committerAlex Legler <a3li@gentoo.org>2010-04-03 08:14:46 +0200
commit750135e305237e54c797dc6da2fc96b5d3a2ca28 (patch)
tree8a4ef03a121644a1bef1675ac7d919c9fca30f9b
parentFix copyright (diff)
downloadruby-scripts-750135e305237e54c797dc6da2fc96b5d3a2ca28.tar.gz
ruby-scripts-750135e305237e54c797dc6da2fc96b5d3a2ca28.tar.bz2
ruby-scripts-750135e305237e54c797dc6da2fc96b5d3a2ca28.zip
ruby-enterprise-1.8.7.2010.01 patchsetpatchset-ee-1.8.7.2010.01
-rw-r--r--patchsets/distfiles/ruby-patches-ee-1.8.7.2010.01.tar.bz2bin0 -> 1975 bytes
-rw-r--r--patchsets/patches-ee-1.8.7.2010.01/001_memory_leak.patch60
-rw-r--r--patchsets/patches-ee-1.8.7.2010.01/002_mkconfig.patch14
-rw-r--r--patchsets/patches-ee-1.8.7.2010.01/003_mkmf-parallel-install.patch14
-rw-r--r--patchsets/patches-ee-1.8.7.2010.01/050_configure-libdir.patch11
-rw-r--r--patchsets/patches-ee-1.8.7.2010.01/051_mkconfig-libdir.patch14
-rw-r--r--patchsets/patches-ee-1.8.7.2010.01/100_pathname_warning.patch14
7 files changed, 127 insertions, 0 deletions
diff --git a/patchsets/distfiles/ruby-patches-ee-1.8.7.2010.01.tar.bz2 b/patchsets/distfiles/ruby-patches-ee-1.8.7.2010.01.tar.bz2
new file mode 100644
index 0000000..f5bb394
--- /dev/null
+++ b/patchsets/distfiles/ruby-patches-ee-1.8.7.2010.01.tar.bz2
Binary files differ
diff --git a/patchsets/patches-ee-1.8.7.2010.01/001_memory_leak.patch b/patchsets/patches-ee-1.8.7.2010.01/001_memory_leak.patch
new file mode 100644
index 0000000..5be0314
--- /dev/null
+++ b/patchsets/patches-ee-1.8.7.2010.01/001_memory_leak.patch
@@ -0,0 +1,60 @@
+Index: ptr.c
+===================================================================
+--- ext/dl/ptr.c (revision 12047)
++++ ext/dl/ptr.c (working copy)
+@@ -53,6 +53,8 @@
+ void
+ dlptr_free(struct ptr_data *data)
+ {
++ if (!data)
++ return;
+ if (data->ptr) {
+ DEBUG_CODE({
+ printf("dlptr_free(): removing the pointer `0x%x' from the MemorySpace\n",
+@@ -69,4 +71,5 @@
+ if (data->stype) dlfree(data->stype);
+ if (data->ssize) dlfree(data->ssize);
+ if (data->ids) dlfree(data->ids);
++ dlfree(data);
+ }
+
+ void
+Index: sym.c
+===================================================================
+--- ext/dl/sym.c (revision 12047)
++++ ext/dl/sym.c (working copy)
+@@ -57,6 +57,8 @@
+ void
+ dlsym_free(struct sym_data *data)
+ {
++ if(!data)
++ return;
+ if( data->name ){
+ DEBUG_CODE({
+ printf("dlsym_free(): free(data->name:%s)\n",data->name);
+@@ -69,4 +71,5 @@
+ });
+ free(data->type);
+ }
++ dlfree(data);
+ }
+
+ VALUE
+Index: handle.c
+===================================================================
+--- ext/dl/handle.c (revision 12047)
++++ ext/dl/handle.c (working copy)
+@@ -10,7 +10,10 @@
+ void
+ dlhandle_free(struct dl_handle *dlhandle)
+ {
++ if (!dlhandle)
++ return;
+ if (dlhandle->ptr && dlhandle->open && dlhandle->enable_close) {
+- dlclose(dlhandle->ptr);
++ dlclose(dlhandle->ptr);
+ }
++ dlfree(dlhandle);
+ }
+
+ VALUE
diff --git a/patchsets/patches-ee-1.8.7.2010.01/002_mkconfig.patch b/patchsets/patches-ee-1.8.7.2010.01/002_mkconfig.patch
new file mode 100644
index 0000000..4426ef9
--- /dev/null
+++ b/patchsets/patches-ee-1.8.7.2010.01/002_mkconfig.patch
@@ -0,0 +1,14 @@
+Fix for mkconfig to be able to handle empty continued lines.
+Patch from [ruby-core:20420] via bug 234877.
+
+--- mkconfig.rb.orig 2008-06-08 01:37:10.000000000 +0900
++++ mkconfig.rb 2009-02-12 13:39:02.000000000 +0900
+@@ -54,7 +54,7 @@
+ continued_name = name
+ next
+ end
+- when /^"(.+)"\s*(\\)?$/
++ when /^"(.*)"\s*(\\)?$/
+ if continued_line
+ continued_line << $1
+ unless $2
diff --git a/patchsets/patches-ee-1.8.7.2010.01/003_mkmf-parallel-install.patch b/patchsets/patches-ee-1.8.7.2010.01/003_mkmf-parallel-install.patch
new file mode 100644
index 0000000..26c05bb
--- /dev/null
+++ b/patchsets/patches-ee-1.8.7.2010.01/003_mkmf-parallel-install.patch
@@ -0,0 +1,14 @@
+ Patch for bug 239101 by Matsuu Takuto, via Redmine issue 1337 (yes, really).
+ Backported for 1.8.* by Alex Legler.
+
+--- lib/mkmf.orig 2009-04-03 13:04:17.000000000 +0200
++++ lib/mkmf.rb 2009-04-03 13:04:30.000000000 +0200
+@@ -1500,7 +1500,7 @@
+ dest = "#{dir}/#{f}"
+ mfile.puts dir, "install-so: #{dest}"
+ unless $extout
+- mfile.print "#{dest}: #{f}\n"
++ mfile.print "#{dest}: #{dir} #{f}\n"
+ if (sep = config_string('BUILD_FILE_SEPARATOR'))
+ f.gsub!("/", sep)
+ dir.gsub!("/", sep)
diff --git a/patchsets/patches-ee-1.8.7.2010.01/050_configure-libdir.patch b/patchsets/patches-ee-1.8.7.2010.01/050_configure-libdir.patch
new file mode 100644
index 0000000..3cb8c4f
--- /dev/null
+++ b/patchsets/patches-ee-1.8.7.2010.01/050_configure-libdir.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2010-04-02 19:21:54.459619901 +0200
++++ configure.in 2010-04-02 19:23:20.251620949 +0200
+@@ -1730,7 +1730,7 @@
+ rubyw_install_name="$RUBYW_INSTALL_NAME"
+ ;;
+ esac
+-RUBY_LIB_PREFIX=`eval echo \\"${libdir}/ruby\\"`
++RUBY_LIB_PREFIX=`eval echo \\"${libdir}/rubyee\\"`
+
+ AC_ARG_WITH(sitedir,
+ [ --with-sitedir=DIR site libraries in DIR [[LIBDIR/ruby/site_ruby]]],
diff --git a/patchsets/patches-ee-1.8.7.2010.01/051_mkconfig-libdir.patch b/patchsets/patches-ee-1.8.7.2010.01/051_mkconfig-libdir.patch
new file mode 100644
index 0000000..a6426ba
--- /dev/null
+++ b/patchsets/patches-ee-1.8.7.2010.01/051_mkconfig-libdir.patch
@@ -0,0 +1,14 @@
+Evil hack fiddling with the ruby libdir
+
+diff -ru a/mkconfig.rb b/mkconfig.rb
+--- a/mkconfig.rb 2008-12-10 23:06:54.000000000 +0100
++++ b/mkconfig.rb 2008-12-10 23:07:41.000000000 +0100
+@@ -139,7 +139,7 @@
+ print(*v_others)
+ print <<EOS
+ CONFIG["ruby_version"] = "$(MAJOR).$(MINOR)"
+- CONFIG["rubylibdir"] = "$(libdir)/ruby/$(ruby_version)"
++ CONFIG["rubylibdir"] = "$(libdir)/rubyee/$(ruby_version)"
+ CONFIG["archdir"] = "$(rubylibdir)/$(arch)"
+ CONFIG["sitelibdir"] = "$(sitedir)/$(ruby_version)"
+ CONFIG["sitearchdir"] = "$(sitelibdir)/$(sitearch)"
diff --git a/patchsets/patches-ee-1.8.7.2010.01/100_pathname_warning.patch b/patchsets/patches-ee-1.8.7.2010.01/100_pathname_warning.patch
new file mode 100644
index 0000000..664408d
--- /dev/null
+++ b/patchsets/patches-ee-1.8.7.2010.01/100_pathname_warning.patch
@@ -0,0 +1,14 @@
+Fix a warning shown in Pathname#sub. Asked upstream for inclusion in redmine
+issue 2538 -a3li
+
+--- branches/ruby_1_8/lib/pathname.rb 2009/03/17 05:56:59 22988
++++ branches/ruby_1_8/lib/pathname.rb 2009/05/18 12:47:24 23485
+@@ -260,7 +260,7 @@
+ ensure
+ Thread.current[:pathname_sub_matchdata] = old
+ end
+- yield *args
++ yield(*args)
+ }
+ else
+ path = @path.sub(pattern, *rest)