aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'testdata/repos')
-rw-r--r--testdata/repos/python/dev-python/PythonMismatchedPackageName0/PythonMismatchedPackageName0-0.ebuild9
-rw-r--r--testdata/repos/python/dev-python/PythonMismatchedPackageName0/metadata.xml7
-rw-r--r--testdata/repos/python/dev-python/PythonMismatchedPackageName1/PythonMismatchedPackageName1-0.ebuild9
-rw-r--r--testdata/repos/python/dev-python/PythonMismatchedPackageName1/metadata.xml7
-rw-r--r--testdata/repos/python/dev-python/PythonMismatchedPackageName3/PythonMismatchedPackageName3-0.ebuild9
-rw-r--r--testdata/repos/python/dev-python/PythonMismatchedPackageName3/metadata.xml8
-rw-r--r--testdata/repos/python/dev-python/python-mismatched-package-name/metadata.xml7
-rw-r--r--testdata/repos/python/dev-python/python-mismatched-package-name/python-mismatched-package-name-0.ebuild9
8 files changed, 65 insertions, 0 deletions
diff --git a/testdata/repos/python/dev-python/PythonMismatchedPackageName0/PythonMismatchedPackageName0-0.ebuild b/testdata/repos/python/dev-python/PythonMismatchedPackageName0/PythonMismatchedPackageName0-0.ebuild
new file mode 100644
index 00000000..0c3de1e6
--- /dev/null
+++ b/testdata/repos/python/dev-python/PythonMismatchedPackageName0/PythonMismatchedPackageName0-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ebuild with matching name with PyPI"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+LICENSE="BSD"
+SLOT="0"
diff --git a/testdata/repos/python/dev-python/PythonMismatchedPackageName0/metadata.xml b/testdata/repos/python/dev-python/PythonMismatchedPackageName0/metadata.xml
new file mode 100644
index 00000000..07ce2e64
--- /dev/null
+++ b/testdata/repos/python/dev-python/PythonMismatchedPackageName0/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">PythonMismatchedPackageName0</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/testdata/repos/python/dev-python/PythonMismatchedPackageName1/PythonMismatchedPackageName1-0.ebuild b/testdata/repos/python/dev-python/PythonMismatchedPackageName1/PythonMismatchedPackageName1-0.ebuild
new file mode 100644
index 00000000..450671b5
--- /dev/null
+++ b/testdata/repos/python/dev-python/PythonMismatchedPackageName1/PythonMismatchedPackageName1-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ebuild with not matching name with PyPI"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+LICENSE="BSD"
+SLOT="0"
diff --git a/testdata/repos/python/dev-python/PythonMismatchedPackageName1/metadata.xml b/testdata/repos/python/dev-python/PythonMismatchedPackageName1/metadata.xml
new file mode 100644
index 00000000..14221de3
--- /dev/null
+++ b/testdata/repos/python/dev-python/PythonMismatchedPackageName1/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">MismatchedPackageName1</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/testdata/repos/python/dev-python/PythonMismatchedPackageName3/PythonMismatchedPackageName3-0.ebuild b/testdata/repos/python/dev-python/PythonMismatchedPackageName3/PythonMismatchedPackageName3-0.ebuild
new file mode 100644
index 00000000..6126af5d
--- /dev/null
+++ b/testdata/repos/python/dev-python/PythonMismatchedPackageName3/PythonMismatchedPackageName3-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ebuild with multiple not matching name with PyPI"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+LICENSE="BSD"
+SLOT="0"
diff --git a/testdata/repos/python/dev-python/PythonMismatchedPackageName3/metadata.xml b/testdata/repos/python/dev-python/PythonMismatchedPackageName3/metadata.xml
new file mode 100644
index 00000000..3601354e
--- /dev/null
+++ b/testdata/repos/python/dev-python/PythonMismatchedPackageName3/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">MismatchedPackageName3</remote-id>
+ <remote-id type="pypi">PackageName3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/testdata/repos/python/dev-python/python-mismatched-package-name/metadata.xml b/testdata/repos/python/dev-python/python-mismatched-package-name/metadata.xml
new file mode 100644
index 00000000..10320a70
--- /dev/null
+++ b/testdata/repos/python/dev-python/python-mismatched-package-name/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">python.mismatched.package.name</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/testdata/repos/python/dev-python/python-mismatched-package-name/python-mismatched-package-name-0.ebuild b/testdata/repos/python/dev-python/python-mismatched-package-name/python-mismatched-package-name-0.ebuild
new file mode 100644
index 00000000..0c3de1e6
--- /dev/null
+++ b/testdata/repos/python/dev-python/python-mismatched-package-name/python-mismatched-package-name-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ebuild with matching name with PyPI"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+LICENSE="BSD"
+SLOT="0"