aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile2
-rw-r--r--system-services.in13
3 files changed, 15 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 219a620..81b97ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,6 @@ system-auth
system-login
system-local-login
system-remote-login
+system-services
other
pambase-*.tar.bz2
diff --git a/Makefile b/Makefile
index 229927e..fc230b3 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
CPP=cpp
# The pam.d file to create
-PAMD=system-auth system-login system-local-login system-remote-login other
+PAMD=system-auth system-login system-local-login system-remote-login system-services other
# command for git (the DVCS); set this to "true" to ignore GIT support
# (i.e.: in the ebuild)
diff --git a/system-services.in b/system-services.in
new file mode 100644
index 0000000..9d4aea1
--- /dev/null
+++ b/system-services.in
@@ -0,0 +1,13 @@
+#if HAVE_LIMITS
+session required pam_limits.so DEBUG
+#endif
+#if HAVE_ENV
+session required pam_env.so DEBUG
+#endif
+#if HAVE_MKTEMP
+session optional pam_mktemp.so
+#endif
+#if SUPPORT_UNIX_SESSION
+session required pam_unix.so DEBUG
+#endif
+session optional pam_permit.so