summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-03-02 17:36:08 -0500
committerMike Pagano <mpagano@gentoo.org>2024-03-02 17:36:08 -0500
commit917982656114eea0e5d207b9d0a3ef662ca9fc0d (patch)
treecccd550dde8f4d76453f38b668737b85c42ed2bf
parentLinux patch 6.7.7 (diff)
downloadlinux-patches-917982656114eea0e5d207b9d0a3ef662ca9fc0d.tar.gz
linux-patches-917982656114eea0e5d207b9d0a3ef662ca9fc0d.tar.bz2
linux-patches-917982656114eea0e5d207b9d0a3ef662ca9fc0d.zip
Linux patch 6.7.86.7-12
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1007_linux-6.7.8.patch33
2 files changed, 37 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 178ef64f..83109cbf 100644
--- a/0000_README
+++ b/0000_README
@@ -71,6 +71,10 @@ Patch: 1006_linux-6.7.7.patch
From: https://www.kernel.org
Desc: Linux 6.7.7
+Patch: 1007_linux-6.7.8.patch
+From: https://www.kernel.org
+Desc: Linux 6.7.8
+
Patch: 1510_fs-enable-link-security-restrictions-by-default.patch
From: http://sources.debian.net/src/linux/3.16.7-ckt4-3/debian/patches/debian/fs-enable-link-security-restrictions-by-default.patch/
Desc: Enable link security restrictions by default.
diff --git a/1007_linux-6.7.8.patch b/1007_linux-6.7.8.patch
new file mode 100644
index 00000000..fd9c8745
--- /dev/null
+++ b/1007_linux-6.7.8.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index 72ee3609aae34..6569f2255d500 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 6
+ PATCHLEVEL = 7
+-SUBLEVEL = 7
++SUBLEVEL = 8
+ EXTRAVERSION =
+ NAME = Hurr durr I'ma ninja sloth
+
+diff --git a/fs/ntfs3/frecord.c b/fs/ntfs3/frecord.c
+index 3b42938a9d3b2..7f27382e0ce25 100644
+--- a/fs/ntfs3/frecord.c
++++ b/fs/ntfs3/frecord.c
+@@ -2457,7 +2457,6 @@ int ni_read_frame(struct ntfs_inode *ni, u64 frame_vbo, struct page **pages,
+ struct ATTR_LIST_ENTRY *le = NULL;
+ struct runs_tree *run = &ni->file.run;
+ u64 valid_size = ni->i_valid;
+- loff_t i_size = i_size_read(&ni->vfs_inode);
+ u64 vbo_disk;
+ size_t unc_size;
+ u32 frame_size, i, npages_disk, ondisk_size;
+@@ -2509,6 +2508,7 @@ int ni_read_frame(struct ntfs_inode *ni, u64 frame_vbo, struct page **pages,
+ err = -EOPNOTSUPP;
+ goto out1;
+ #else
++ loff_t i_size = i_size_read(&ni->vfs_inode);
+ u32 frame_bits = ni_ext_compress_bits(ni);
+ u64 frame64 = frame_vbo >> frame_bits;
+ u64 frames, vbo_data;