summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-07-15 07:15:25 -0400
committerMike Pagano <mpagano@gentoo.org>2024-07-15 07:15:25 -0400
commit7617cf4a5b2ad10825dd602fc59864c82a6c3ded (patch)
treef20dd80442f5da7ea832d55fac4eef24423ca662
parentLinux patch 6.6.39 (diff)
downloadlinux-patches-7617cf4a5b2ad10825dd602fc59864c82a6c3ded.tar.gz
linux-patches-7617cf4a5b2ad10825dd602fc59864c82a6c3ded.tar.bz2
linux-patches-7617cf4a5b2ad10825dd602fc59864c82a6c3ded.zip
Linux patch 6.6.406.6-47
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1039_linux-6.6.40.patch37
2 files changed, 41 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 974c1f33..851873fc 100644
--- a/0000_README
+++ b/0000_README
@@ -199,6 +199,10 @@ Patch: 1038_linux-6.6.39.patch
From: https://www.kernel.org
Desc: Linux 6.6.39
+Patch: 1039_linux-6.6.40.patch
+From: https://www.kernel.org
+Desc: Linux 6.6.40
+
Patch: 1510_fs-enable-link-security-restrictions-by-default.patch
From: http://sources.debian.net/src/linux/3.16.7-ckt4-3/debian/patches/debian/fs-enable-link-security-restrictions-by-default.patch
Desc: Enable link security restrictions by default.
diff --git a/1039_linux-6.6.40.patch b/1039_linux-6.6.40.patch
new file mode 100644
index 00000000..48ba9027
--- /dev/null
+++ b/1039_linux-6.6.40.patch
@@ -0,0 +1,37 @@
+diff --git a/Makefile b/Makefile
+index 5ba70f0649f3c..c844130774569 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 6
+ PATCHLEVEL = 6
+-SUBLEVEL = 39
++SUBLEVEL = 40
+ EXTRAVERSION =
+ NAME = Hurr durr I'ma ninja sloth
+
+diff --git a/drivers/usb/host/xhci-ring.c b/drivers/usb/host/xhci-ring.c
+index 592dabc785152..8dd85221cd927 100644
+--- a/drivers/usb/host/xhci-ring.c
++++ b/drivers/usb/host/xhci-ring.c
+@@ -2649,17 +2649,16 @@ static int handle_tx_event(struct xhci_hcd *xhci,
+ else
+ xhci_handle_halted_endpoint(xhci, ep, NULL,
+ EP_SOFT_RESET);
+- break;
++ goto cleanup;
+ case COMP_RING_UNDERRUN:
+ case COMP_RING_OVERRUN:
+ case COMP_STOPPED_LENGTH_INVALID:
+- break;
++ goto cleanup;
+ default:
+ xhci_err(xhci, "ERROR Transfer event for unknown stream ring slot %u ep %u\n",
+ slot_id, ep_index);
+ goto err_out;
+ }
+- return 0;
+ }
+
+ /* Count current td numbers if ep->skip is set */