summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-07-07 09:13:41 -0400
committerMike Pagano <mpagano@gentoo.org>2021-07-07 09:13:41 -0400
commit3f55297e81ec138d4f07ea6417d3a869e93f1923 (patch)
tree7136574d0afdc3cb540b2e8c516ea865ce46247b
parentLinux patch 5.4.129 (diff)
downloadlinux-patches-3f55297e81ec138d4f07ea6417d3a869e93f1923.tar.gz
linux-patches-3f55297e81ec138d4f07ea6417d3a869e93f1923.tar.bz2
linux-patches-3f55297e81ec138d4f07ea6417d3a869e93f1923.zip
Linux patch 5.4.1305.4-134
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1129_linux-5.4.130.patch110
2 files changed, 114 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index bedf8eaf..016d1fd9 100644
--- a/0000_README
+++ b/0000_README
@@ -559,6 +559,10 @@ Patch: 1128_linux-5.4.129.patch
From: http://www.kernel.org
Desc: Linux 5.4.129
+Patch: 1129_linux-5.4.130.patch
+From: http://www.kernel.org
+Desc: Linux 5.4.130
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1129_linux-5.4.130.patch b/1129_linux-5.4.130.patch
new file mode 100644
index 00000000..e874e175
--- /dev/null
+++ b/1129_linux-5.4.130.patch
@@ -0,0 +1,110 @@
+diff --git a/Makefile b/Makefile
+index 802520ad08cca..4256dd594d18c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 4
+-SUBLEVEL = 129
++SUBLEVEL = 130
+ EXTRAVERSION =
+ NAME = Kleptomaniac Octopus
+
+diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
+index f9263426af030..ae414045a7506 100644
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -1232,6 +1232,7 @@ config GPIO_TPS68470
+ config GPIO_TQMX86
+ tristate "TQ-Systems QTMX86 GPIO"
+ depends on MFD_TQMX86 || COMPILE_TEST
++ depends on HAS_IOPORT_MAP
+ select GPIOLIB_IRQCHIP
+ help
+ This driver supports GPIO on the TQMX86 IO controller.
+@@ -1299,6 +1300,7 @@ menu "PCI GPIO expanders"
+ config GPIO_AMD8111
+ tristate "AMD 8111 GPIO driver"
+ depends on X86 || COMPILE_TEST
++ depends on HAS_IOPORT_MAP
+ help
+ The AMD 8111 south bridge contains 32 GPIO pins which can be used.
+
+diff --git a/drivers/gpu/drm/nouveau/nouveau_bo.c b/drivers/gpu/drm/nouveau/nouveau_bo.c
+index f8015e0318d71..f7603be569fc9 100644
+--- a/drivers/gpu/drm/nouveau/nouveau_bo.c
++++ b/drivers/gpu/drm/nouveau/nouveau_bo.c
+@@ -542,7 +542,7 @@ nouveau_bo_sync_for_device(struct nouveau_bo *nvbo)
+ struct ttm_dma_tt *ttm_dma = (struct ttm_dma_tt *)nvbo->bo.ttm;
+ int i;
+
+- if (!ttm_dma)
++ if (!ttm_dma || !ttm_dma->dma_address)
+ return;
+
+ /* Don't waste time looping if the object is coherent */
+@@ -562,7 +562,7 @@ nouveau_bo_sync_for_cpu(struct nouveau_bo *nvbo)
+ struct ttm_dma_tt *ttm_dma = (struct ttm_dma_tt *)nvbo->bo.ttm;
+ int i;
+
+- if (!ttm_dma)
++ if (!ttm_dma || !ttm_dma->dma_address)
+ return;
+
+ /* Don't waste time looping if the object is coherent */
+diff --git a/drivers/infiniband/hw/mlx5/flow.c b/drivers/infiniband/hw/mlx5/flow.c
+index b198ff10cde96..fddefb29efd76 100644
+--- a/drivers/infiniband/hw/mlx5/flow.c
++++ b/drivers/infiniband/hw/mlx5/flow.c
+@@ -13,6 +13,7 @@
+ #include <rdma/ib_umem.h>
+ #include <linux/mlx5/driver.h>
+ #include <linux/mlx5/fs.h>
++#include <linux/mlx5/eswitch.h>
+ #include "mlx5_ib.h"
+
+ #define UVERBS_MODULE_NAME mlx5_ib
+@@ -316,6 +317,13 @@ static int UVERBS_HANDLER(MLX5_IB_METHOD_FLOW_MATCHER_CREATE)(
+ if (err)
+ goto end;
+
++ if (obj->ns_type == MLX5_FLOW_NAMESPACE_FDB &&
++ mlx5_eswitch_mode(dev->mdev->priv.eswitch) !=
++ MLX5_ESWITCH_OFFLOADS) {
++ err = -EINVAL;
++ goto end;
++ }
++
+ uobj->object = obj;
+ obj->mdev = dev->mdev;
+ atomic_set(&obj->usecnt, 0);
+diff --git a/drivers/scsi/sr.c b/drivers/scsi/sr.c
+index 70a28f6fb1d0d..2332b245b182d 100644
+--- a/drivers/scsi/sr.c
++++ b/drivers/scsi/sr.c
+@@ -218,6 +218,8 @@ static unsigned int sr_get_events(struct scsi_device *sdev)
+ return DISK_EVENT_EJECT_REQUEST;
+ else if (med->media_event_code == 2)
+ return DISK_EVENT_MEDIA_CHANGE;
++ else if (med->media_event_code == 3)
++ return DISK_EVENT_EJECT_REQUEST;
+ return 0;
+ }
+
+diff --git a/security/integrity/platform_certs/load_uefi.c b/security/integrity/platform_certs/load_uefi.c
+index aa874d84e413e..f0c908241966a 100644
+--- a/security/integrity/platform_certs/load_uefi.c
++++ b/security/integrity/platform_certs/load_uefi.c
+@@ -11,11 +11,6 @@
+ #include "../integrity.h"
+ #include "keyring_handler.h"
+
+-static efi_guid_t efi_cert_x509_guid __initdata = EFI_CERT_X509_GUID;
+-static efi_guid_t efi_cert_x509_sha256_guid __initdata =
+- EFI_CERT_X509_SHA256_GUID;
+-static efi_guid_t efi_cert_sha256_guid __initdata = EFI_CERT_SHA256_GUID;
+-
+ /*
+ * Look to see if a UEFI variable called MokIgnoreDB exists and return true if
+ * it does.