summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-05-30 18:33:52 -0400
committerMike Pagano <mpagano@gentoo.org>2018-05-30 18:33:52 -0400
commit6249086451bf9c65061b1b7c2bb66c6d4b661930 (patch)
tree68c537d92a3d6885e5c04e673fe52eb5a966e90e
parentLinux patch 4.9.104 (diff)
downloadlinux-patches-6249086451bf9c65061b1b7c2bb66c6d4b661930.tar.gz
linux-patches-6249086451bf9c65061b1b7c2bb66c6d4b661930.tar.bz2
linux-patches-6249086451bf9c65061b1b7c2bb66c6d4b661930.zip
Linux 4.9.1054.9-108
-rw-r--r--0000_README4
-rw-r--r--1104_linux-4.9.105.patch24
2 files changed, 28 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index e808f940..acb79259 100644
--- a/0000_README
+++ b/0000_README
@@ -459,6 +459,10 @@ Patch: 1103_linux-4.9.104.patch
From: http://www.kernel.org
Desc: Linux 4.9.104
+Patch: 1104_linux-4.9.105.patch
+From: http://www.kernel.org
+Desc: Linux 4.9.105
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1104_linux-4.9.105.patch b/1104_linux-4.9.105.patch
new file mode 100644
index 00000000..7831777d
--- /dev/null
+++ b/1104_linux-4.9.105.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index 780dcc8033b2..7d06dba3fde8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 9
+-SUBLEVEL = 104
++SUBLEVEL = 105
+ EXTRAVERSION =
+ NAME = Roaring Lionus
+
+diff --git a/net/ipv4/ip_vti.c b/net/ipv4/ip_vti.c
+index 1ac55b116d5a..cbff0d6ff1ac 100644
+--- a/net/ipv4/ip_vti.c
++++ b/net/ipv4/ip_vti.c
+@@ -396,6 +396,7 @@ static int vti_tunnel_init(struct net_device *dev)
+ memcpy(dev->dev_addr, &iph->saddr, 4);
+ memcpy(dev->broadcast, &iph->daddr, 4);
+
++ dev->mtu = ETH_DATA_LEN;
+ dev->flags = IFF_NOARP;
+ dev->addr_len = 4;
+ dev->features |= NETIF_F_LLTX;