aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2012-03-31 12:55:41 +0100
committerDaniel P. Berrange <berrange@redhat.com>2012-03-31 13:22:40 +0100
commit8bf0442e833f93b88c0615bece90151041aaa0d4 (patch)
treec3f09f7ef6bb0c826ad04fe81ceae3469d87727d /examples
parentRefactor the libvirt RPM daemon pieces (diff)
downloadlibvirt-8bf0442e833f93b88c0615bece90151041aaa0d4.tar.gz
libvirt-8bf0442e833f93b88c0615bece90151041aaa0d4.tar.bz2
libvirt-8bf0442e833f93b88c0615bece90151041aaa0d4.zip
Fix client only RPM build & other misc RPM problems
* libvirt.spec.in: Remove obsolete --with-remote-pid-file arg. Add missing %{without_libxl} statement. Fix handling of docs in client only build. Put systemtap files in -client RPM instead of -daemon RPM * examples/xml/nwfilter/Makefile.am: Don't install examples if nwfilter is disabled.
Diffstat (limited to 'examples')
-rw-r--r--examples/xml/nwfilter/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/examples/xml/nwfilter/Makefile.am b/examples/xml/nwfilter/Makefile.am
index 12a36198c..c503682bb 100644
--- a/examples/xml/nwfilter/Makefile.am
+++ b/examples/xml/nwfilter/Makefile.am
@@ -22,6 +22,7 @@ FILTERS = \
EXTRA_DIST=$(FILTERS)
+if WITH_NWFILTER
confdir = $(sysconfdir)/libvirt
NWFILTER_DIR = "$(DESTDIR)$(sysconfdir)/libvirt/nwfilter"
@@ -37,3 +38,4 @@ uninstall-local::
rm -f "$(NWFILTER_DIR)/$$f"; \
done
-test -z $(shell ls $(NWFILTER_DIR)) || rmdir $(NWFILTER_DIR)
+endif