aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-06-28 09:50:11 -0600
committerEric Blake <eblake@redhat.com>2011-06-30 16:45:56 -0600
commitaddaa5374c80c08c1f5483c381f71962c677ad53 (patch)
treef0ad0a228f0333ae7f453c9c8ae06dc95207f186
parentbuild: ignore generated file (diff)
downloadlibvirt-addaa5374c80c08c1f5483c381f71962c677ad53.tar.gz
libvirt-addaa5374c80c08c1f5483c381f71962c677ad53.tar.bz2
libvirt-addaa5374c80c08c1f5483c381f71962c677ad53.zip
build: allow 'make syntax-check' on fresh checkout
For good or for bad, I did a fresh checkout, ./autogen.sh, then 'configure', then 'make syntax-check', and was surprised that it failed. Running 'make' before 'make syntax-check' cleaned up the issue, but this patch makes it work up front. * cfg.mk (sc_po_check): Add prerequisites.
-rw-r--r--cfg.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/cfg.mk b/cfg.mk
index 69f35a35f..b00cda365 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -605,6 +605,14 @@ _autogen:
# regenerate HACKING as part of the syntax-check
syntax-check: $(top_srcdir)/HACKING
+# sc_po_check can fail if generated files are not built first
+sc_po_check: $(srcdir)/daemon/remote_dispatch.h \
+ $(srcdir)/src/remote/remote_client_bodies.h
+$(srcdir)/daemon/remote_dispatch.h:
+ $(MAKE) -C daemon remote_dispatch.h
+$(srcdir)/src/remote/remote_client_bodies.h:
+ $(MAKE) -C src remote/remote_client_bodies.h
+
# List all syntax-check exemptions:
exclude_file_name_regexp--sc_avoid_strcase = ^tools/virsh\.c$$