aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--patches/eudev/3.2.14/eudev-3.2.14-static.patch (renamed from patches/eudev/3.2.10/eudev-3.2.10-static.patch)17
1 files changed, 8 insertions, 9 deletions
diff --git a/patches/eudev/3.2.10/eudev-3.2.10-static.patch b/patches/eudev/3.2.14/eudev-3.2.14-static.patch
index fc36b547..88bc1e15 100644
--- a/patches/eudev/3.2.10/eudev-3.2.10-static.patch
+++ b/patches/eudev/3.2.14/eudev-3.2.14-static.patch
@@ -1,14 +1,14 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -261,7 +261,7 @@ AC_ARG_ENABLE(kmod, AS_HELP_STRING([--disable-kmod], [disable loadable modules s
+@@ -252,7 +252,7 @@ AC_ARG_ENABLE(kmod, AS_HELP_STRING([--disable-kmod], [disable loadable modules s
if test "x$enable_kmod" != "xno"; then
- PKG_CHECK_EXISTS([ libkmod ], have_kmod=yes, have_kmod=no)
- if test "x$have_kmod" = "xyes"; then
-- PKG_CHECK_MODULES(KMOD, [ libkmod >= 15 ],
-+ PKG_CHECK_MODULES_STATIC(KMOD, [ libkmod >= 15 ],
- [AC_DEFINE(HAVE_KMOD, 1, [Define if kmod is available])],
- AC_MSG_ERROR([*** kmod version >= 15 not found]))
- fi
+ PKG_CHECK_EXISTS([ libkmod ], have_kmod=yes, have_kmod=no)
+ if test "x$have_kmod" = "xyes"; then
+- PKG_CHECK_MODULES(KMOD, [ libkmod >= 15 ],
++ PKG_CHECK_MODULES_STATIC(KMOD, [ libkmod >= 15 ],
+ [AC_DEFINE(HAVE_KMOD, 1, [Define if kmod is available])],
+ AC_MSG_ERROR([*** kmod version >= 15 not found]))
+ fi
--- a/src/ata_id/Makefile.am
+++ b/src/ata_id/Makefile.am
@@ -11,6 +11,8 @@ udevlibexec_PROGRAMS = \
@@ -94,4 +94,3 @@
v4l_id_LDADD = \
$(top_builddir)/src/libudev/libudev-private.la \
$(top_builddir)/src/udev/libudev-core.la
-