summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lcms2mt/configure.ac')
-rw-r--r--lcms2mt/configure.ac51
1 files changed, 28 insertions, 23 deletions
diff --git a/lcms2mt/configure.ac b/lcms2mt/configure.ac
index e347750f..439ca550 100644
--- a/lcms2mt/configure.ac
+++ b/lcms2mt/configure.ac
@@ -7,34 +7,16 @@ AC_PREREQ(2.60)
#
# Set the package name and version
#
-AC_INIT(lcms2mt,2.10)
+AC_INIT(lcms2mt,2.12)
# Specify directory where m4 macros may be found.
AC_CONFIG_MACRO_DIR([m4])
#
# Libtool library revision control info
-# See the libtool documentation under the heading "Libtool's versioning
-# system" in order to understand the meaning of these fields
-#
-# Here are a set of rules to help you update your library version
-# information:
-#
-# 1. Start with version information of `0:0:0' for each libtool library.
-# 2. Update the version information only immediately before a public
-# release of your software. More frequent updates are unnecessary, and
-# only guarantee that the current interface number gets larger faster.
-# 3. If the library source code has changed at all since the last update,
-# then increment revision (`c:r:a' becomes `c:r+1:a').
-# 4. If any interfaces have been added, removed, or changed since the last
-# update, increment current, and set revision to 0.
-# 5. If any interfaces have been added since the last public release, then
-# increment age.
-# 6. If any interfaces have been removed since the last public release,
-# then set age to 0.
#
LIBRARY_CURRENT=2
-LIBRARY_REVISION=10
+LIBRARY_REVISION=12
LIBRARY_AGE=0
AC_SUBST(LIBRARY_CURRENT)dnl
@@ -44,7 +26,7 @@ AC_SUBST(LIBRARY_AGE)dnl
# Obtain system type by running config.guess
AC_CANONICAL_HOST
-AM_INIT_AUTOMAKE([foreign 1.7.2 no-define dist-zip subdir-objects])
+AM_INIT_AUTOMAKE([foreign 1.9 tar-ustar no-define dist-zip subdir-objects])
# Check for programs
@@ -72,6 +54,8 @@ AC_LIBTOOL_SETUP
AC_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
+LIB_PLUGINS = ''
+
# Add configure option --enable-maintainer-mode which enables dependency
# checking and generation useful to package maintainers. This is made an
# option to avoid confusing end users.
@@ -98,7 +82,7 @@ AC_C_BIGENDIAN
# Point to JPEG installed in DIR or disable JPEG with --without-jpeg.
AC_ARG_WITH(jpeg,
- [ --with-jpeg=DIR use jpeg installed in DIR],
+ AS_HELP_STRING([--with-jpeg=DIR],[use jpeg installed in DIR]),
[
if [ test "x$withval" = "xno" ]; then
[with_jpeg='no']
@@ -116,7 +100,7 @@ AC_ARG_WITH(jpeg,
# Point to TIFF installed in DIR or disable TIFF with --without-tiff.
AC_ARG_WITH(tiff,
- [ --with-tiff=DIR use tiff installed in DIR],
+ AS_HELP_STRING([--with-tiff=DIR], [use tiff installed in DIR]),
[
if [ test "x$withval" = "xno" ]; then
[with_tiff='no']
@@ -138,6 +122,18 @@ AC_ARG_WITH(zlib,
[with_zlib=$withval],
[with_zlib='yes'])
+#fast_float plugin:
+AC_ARG_WITH(fastfloat,
+ AS_HELP_STRING([--with-fastfloat],
+ [build and install fast_float plugin, use only if GPL 3.0 is acceptable]),
+ [
+ with_fastfloat='yes'
+ LIB_PLUGINS="$LIB_PLUGINS -llcms2_fast_float"
+ ],
+ [
+ with_fastfloat='no'
+ ])
+
#
# Determine POSIX threads settings
#
@@ -354,6 +350,9 @@ LCMS_LIB_DEPLIBS="$LIB_MATH $LIB_THREAD"
LCMS_LIB_DEPLIBS=`echo $LCMS_LIB_DEPLIBS | sed -e 's/ */ /g'`
AC_SUBST(LCMS_LIB_DEPLIBS)
+echo "LIB_PLUGINS: $LIB_PLUGINS"
+AC_SUBST(LIB_PLUGINS)
+
# Libraries that the jpegicc program depends on
JPEGICC_DEPLIBS="$LIB_JPEG $LIB_MATH $LIB_THREAD"
JPEGICC_DEPLIBS=`echo $JPEGICC_DEPLIBS | sed -e 's/ */ /g'`
@@ -379,4 +378,10 @@ AC_CONFIG_FILES([utils/linkicc/Makefile])
AC_CONFIG_FILES([utils/jpgicc/Makefile])
AC_CONFIG_FILES([utils/psicc/Makefile])
AC_CONFIG_FILES([testbed/Makefile])
+AM_CONDITIONAL([COND_FASTFLOAT], [test "x$with_fastfloat" = "xyes" ])
+AC_CONFIG_FILES([plugins/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/src/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/include/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/testbed/Makefile])
AC_OUTPUT