summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-03-30 10:59:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-01 00:04:14 +0200
commit5ff1d6955496b3cf9a35042c9ac35db43bc336b1 (patch)
tree6d470f7eb448f59f53e8df1010aec9dad8ce1f72 /tiff/contrib/addtiffo/CMakeLists.txt
parentImport Ghostscript 9.53.1 (diff)
downloadghostscript-gpl-patches-5ff1d6955496b3cf9a35042c9ac35db43bc336b1.tar.gz
ghostscript-gpl-patches-5ff1d6955496b3cf9a35042c9ac35db43bc336b1.tar.bz2
ghostscript-gpl-patches-5ff1d6955496b3cf9a35042c9ac35db43bc336b1.zip
Import Ghostscript 9.54ghostscript-9.54
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'tiff/contrib/addtiffo/CMakeLists.txt')
-rw-r--r--tiff/contrib/addtiffo/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tiff/contrib/addtiffo/CMakeLists.txt b/tiff/contrib/addtiffo/CMakeLists.txt
index b7482635..45e733cd 100644
--- a/tiff/contrib/addtiffo/CMakeLists.txt
+++ b/tiff/contrib/addtiffo/CMakeLists.txt
@@ -32,3 +32,9 @@ include_directories(${PROJECT_SOURCE_DIR}/libtiff
add_executable(addtiffo addtiffo.c tif_overview.c tif_ovrcache.c tif_ovrcache.h)
target_link_libraries(addtiffo tiff port)
+
+if(WEBP_SUPPORT AND EMSCRIPTEN)
+ # Emscripten is pretty finnicky about linker flags.
+ # It needs --shared-memory if and only if atomics or bulk-memory is used.
+ target_link_options(addtiffo PUBLIC "-Wl,--shared-memory")
+endif()