summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/textsecure-apk/textsecure-apk-0.9.9.6.ebuild')
-rw-r--r--app-mobilephone/textsecure-apk/textsecure-apk-0.9.9.6.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-mobilephone/textsecure-apk/textsecure-apk-0.9.9.6.ebuild b/app-mobilephone/textsecure-apk/textsecure-apk-0.9.9.6.ebuild
index 38e97af..45dcbf7 100644
--- a/app-mobilephone/textsecure-apk/textsecure-apk-0.9.9.6.ebuild
+++ b/app-mobilephone/textsecure-apk/textsecure-apk-0.9.9.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
inherit java-pkg-2 java-ant-2
@@ -12,9 +12,10 @@ ABS_P=${ABS_PN}-${ABS_PV}
MY_PN=TextSecure
MY_P=${MY_PN}-${PV}
-DESCRIPTION="A secure text messaging application for Android."
-HOMEPAGE=https://github.com/WhisperSystems/TextSecure
-SRC_URI="https://github.com/WhisperSystems/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz
+DESCRIPTION="A secure text messaging application for Android"
+HOMEPAGE="https://github.com/WhisperSystems/TextSecure"
+SRC_URI="
+ https://github.com/WhisperSystems/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz
https://github.com/JakeWharton/${ABS_PN}/archive/${ABS_PV}.tar.gz -> ${ABS_P}.tar.gz"
LICENSE="GPL-3 Apache-2.0"
@@ -22,12 +23,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=virtual/jdk-1.7
+DEPEND="
+ >=virtual/jdk-1.7:*
dev-util/android-sdk-update-manager"
RDEPEND=">=virtual/jre-1.7"
S=${WORKDIR}
-PROPERTIES=interactive
+
+PROPERTIES=interactive
ANDROID_TARGET=android-15