summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/autoprime/autoprime-2.0.1.ebuild')
-rw-r--r--sci-biology/autoprime/autoprime-2.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/autoprime/autoprime-2.0.1.ebuild b/sci-biology/autoprime/autoprime-2.0.1.ebuild
new file mode 100644
index 0000000..f6b2708
--- /dev/null
+++ b/sci-biology/autoprime/autoprime-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2004-2005 Gunnar Wrobel
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit perl-module
+
+MY_P=${P/autoprime/AutoPrime}
+
+CATEGORY="sci-biology"
+
+DESCRIPTION="A command line tool to generate primers for RT-PCR"
+HOMEPAGE="http://www.autoprime.de/"
+SRC_URI="http://www.gunnarwrobel.de/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=sci-biology/ensembl-perl-33
+ >=sci-biology/repbase-10.07
+ >=sci-biology/primer3-1.0.0
+ "
+
+src_compile()
+{
+ cd ${WORKDIR}/${MY_P}
+
+ perl-module_src_compile
+}
+
+src_install()
+{
+ cd ${WORKDIR}/${MY_P}
+
+ perl-module_src_install
+}