From c5a76d46eb1a7065c8d96851a25b129999a208ff Mon Sep 17 00:00:00 2001
From: Roy Marples <uberlord@gentoo.org>
Date: Fri, 18 Nov 2005 10:19:30 +0000
Subject: Fixed gcc4 compilation warnings (Portage version: 2.0.51.22-r3)

---
 net-misc/pump/ChangeLog                    |   8 ++-
 net-misc/pump/Manifest                     |   9 ++-
 net-misc/pump/files/digest-pump-0.8.21-r8  |   2 +
 net-misc/pump/files/pump-0.8.21-gcc4.patch | 101 +++++++++++++++++++++++++++++
 net-misc/pump/pump-0.8.21-r8.ebuild        |  59 +++++++++++++++++
 5 files changed, 175 insertions(+), 4 deletions(-)
 create mode 100644 net-misc/pump/files/digest-pump-0.8.21-r8
 create mode 100644 net-misc/pump/files/pump-0.8.21-gcc4.patch
 create mode 100644 net-misc/pump/pump-0.8.21-r8.ebuild

(limited to 'net-misc/pump')

diff --git a/net-misc/pump/ChangeLog b/net-misc/pump/ChangeLog
index e26c7d69e764..1986d8e9b30e 100644
--- a/net-misc/pump/ChangeLog
+++ b/net-misc/pump/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/pump
 # Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.26 2005/10/06 06:45:36 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.27 2005/11/18 10:19:30 uberlord Exp $
+
+*pump-0.8.21-r8 (18 Nov 2005)
+
+  18 Nov 2005; Roy Marples <uberlord@gentoo.org>
+  +files/pump-0.8.21-gcc4.patch, +pump-0.8.21-r8.ebuild:
+  Fixed gcc4 compilation warnings
 
   06 Oct 2005; Roy Marples <uberlord@gentoo.org> -files/pump.conf,
   -pump-0.8.11-r1.ebuild, -pump-0.8.19-r1.ebuild:
diff --git a/net-misc/pump/Manifest b/net-misc/pump/Manifest
index a402ba7cfd0e..2dea20b7d99e 100644
--- a/net-misc/pump/Manifest
+++ b/net-misc/pump/Manifest
@@ -1,5 +1,8 @@
-MD5 dd864c5cf876c843e9684c53aaa96f03 ChangeLog 4552
-MD5 d057200fd35820b24f71841abe4fb946 pump-0.8.21-r7.ebuild 1444
+MD5 441a2ab9935a98e8d58e558ca27a3d75 pump-0.8.21-r8.ebuild 1521
 MD5 94fe4b6cace933a6aaedd7fb52194eca metadata.xml 288
-MD5 d392ca15c9b4bd656b2bfdc185ba654d files/pump-0.8.21-gentoo.diff 20131
+MD5 d057200fd35820b24f71841abe4fb946 pump-0.8.21-r7.ebuild 1444
+MD5 dd864c5cf876c843e9684c53aaa96f03 ChangeLog 4552
 MD5 f3e80515c4994d15e18d1c17c0740970 files/digest-pump-0.8.21-r7 132
+MD5 61f260b871807d65909b25eac4a60853 files/pump-0.8.21-gcc4.patch 3244
+MD5 f3e80515c4994d15e18d1c17c0740970 files/digest-pump-0.8.21-r8 132
+MD5 d392ca15c9b4bd656b2bfdc185ba654d files/pump-0.8.21-gentoo.diff 20131
diff --git a/net-misc/pump/files/digest-pump-0.8.21-r8 b/net-misc/pump/files/digest-pump-0.8.21-r8
new file mode 100644
index 000000000000..0a9f7d804d9f
--- /dev/null
+++ b/net-misc/pump/files/digest-pump-0.8.21-r8
@@ -0,0 +1,2 @@
+MD5 a6925de6cd011605237934a907f8a9c4 pump_0.8.21.orig.tar.gz 79289
+MD5 22e1a2a142117fe41781e5437a03fcdb pump_0.8.21-2.diff.gz 22259
diff --git a/net-misc/pump/files/pump-0.8.21-gcc4.patch b/net-misc/pump/files/pump-0.8.21-gcc4.patch
new file mode 100644
index 000000000000..f37392ad17ca
--- /dev/null
+++ b/net-misc/pump/files/pump-0.8.21-gcc4.patch
@@ -0,0 +1,101 @@
+--- pump-0.8.21/pump.c.orig	2005-11-18 09:43:38.634480153 +0000
++++ pump-0.8.21/pump.c	2005-11-18 09:42:26.736658004 +0000
+@@ -306,7 +306,7 @@
+ static void runDaemon(int sock, int sock_in) {
+     int conn;
+     struct sockaddr_un addr;
+-    int addrLength = sizeof(struct sockaddr_un);
++    socklen_t addrLength = sizeof(struct sockaddr_un);
+     struct command cmd;
+     struct pumpNetIntf intf[20];
+     const int maxIntf = sizeof(intf) / sizeof(intf[0]);
+--- pump-0.8.21/dhcp.c.orig	2005-11-18 09:43:46.883546029 +0000
++++ pump-0.8.21/dhcp.c	2005-11-18 09:55:24.672589943 +0000
+@@ -406,7 +406,7 @@
+     unsigned char option, length;
+ 
+    
+-    chptr = response->vendor;
++    chptr = (unsigned char *) response->vendor;
+ 
+     chptr += 4;
+     while (*chptr != 0xFF) {
+@@ -483,7 +483,7 @@
+     intf->set |= PUMP_INTFINFO_HAS_NEXTSERVER;
+     syslog (LOG_DEBUG, "intf: next server: %s", inet_ntoa (intf->nextServer));
+ 
+-    chptr = breq->vendor;
++    chptr = (unsigned char *) breq->vendor;
+     chptr += 4;
+     while (*chptr != 0xFF && (void *) chptr < (void *) breq->vendor + DHCP_VENDOR_LENGTH) {
+ 	option = *chptr++;
+@@ -739,7 +739,7 @@
+     syslog (LOG_DEBUG, "%s: servername: %s", name, breq->servername);
+     syslog (LOG_DEBUG, "%s: bootfile: %s", name, breq->bootfile);
+     
+-    vndptr = breq->vendor;
++    vndptr = (unsigned char *) breq->vendor;
+     sprintf (vendor, "0x%02x 0x%02x 0x%02x 0x%02x", vndptr[0], vndptr[1], vndptr[2], vndptr[3]);
+     vndptr += 4;
+     syslog (LOG_DEBUG, "%s: vendor: %s", name, vendor);
+@@ -751,7 +751,7 @@
+ 	if (option == 0xFF)
+ 	  {
+ 	    sprintf (vendor, "0x%02x", option);
+-	    vndptr = breq->vendor + DHCP_VENDOR_LENGTH;
++	    vndptr = (unsigned char *)breq->vendor + DHCP_VENDOR_LENGTH;
+ 	  }
+ 	else if (option == 0x00)
+ 	  {
+@@ -794,10 +794,11 @@
+     fd_set readfs;
+     int i, j;
+     struct sockaddr_pkt tmpAddress;
++    socklen_t addrLength;
+     int gotit = 0;
+     int tries;
+     int nextTimeout = 2;
+-    time_t timeoutTime;
++    time_t timeoutTime = 0;
+     int sin;
+     int resend = 1;
+     struct ethhdr;
+@@ -884,9 +885,9 @@
+ 	    break;
+ 
+ 	  case 1:
+-	    i = sizeof(tmpAddress);
++	    addrLength = sizeof(tmpAddress);
+ 	    if ((j = recvfrom(sin, ethPacket, sizeof(ethPacket), 0, 
+-		     (struct sockaddr *) &tmpAddress, &i)) < 0)
++		     (struct sockaddr *) &tmpAddress, &addrLength)) < 0)
+ 		return perrorstr("recvfrom");
+ 
+ 	    /* We need to do some basic sanity checking of the header */
+@@ -998,7 +999,7 @@
+     unsigned char * chptr;
+     int theOption, theLength;
+ 
+-    chptr = breq->vendor;
++    chptr = (unsigned char *) breq->vendor;
+     chptr += 4;
+     while (*chptr != 0xFF && *chptr != option) {
+ 	theOption = *chptr++;
+@@ -1018,7 +1019,7 @@
+     unsigned char * chptr;
+     unsigned int length, theOption;
+ 
+-    chptr = bresp->vendor;
++    chptr = (unsigned char *) bresp->vendor;
+     chptr += 4;
+     while (*chptr != 0xFF && *chptr != option) {
+ 	theOption = *chptr++;
+@@ -1290,7 +1291,7 @@
+     struct sockaddr_in serverAddr;
+     struct sockaddr_ll broadcastAddr;
+     struct bootpRequest breq, bresp;
+-    unsigned char * chptr;
++    char * chptr;
+     time_t startTime = pumpUptime();
+     char * saveDeviceName;
+     unsigned char messageType;
diff --git a/net-misc/pump/pump-0.8.21-r8.ebuild b/net-misc/pump/pump-0.8.21-r8.ebuild
new file mode 100644
index 000000000000..d1b83bbc0ba4
--- /dev/null
+++ b/net-misc/pump/pump-0.8.21-r8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.21-r8.ebuild,v 1.1 2005/11/18 10:19:30 uberlord Exp $
+
+inherit eutils
+
+PATCHLEVEL="2"
+
+DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
+	mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/popt-1.5"
+
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+	cd "${WORKDIR}"
+	unpack "${PN}_${PV}.orig.tar.gz"
+
+	# Apply Debians pump patchset - they fix things good :)
+	epatch "${DISTDIR}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
+
+	# Enable the -e (--etc-dir) option to specify where to make
+	# resolv.conf - default /etc
+	# Enable the -m (--route-metric) option to specify the default
+	# metric applied to routes
+	# Enable the --keep-up option to keep interfaces up when we release
+	# Enable the creation of /etc/ntp.conf and the --no-ntp option
+	epatch "${FILESDIR}/pump-${PV}-gentoo.diff"
+
+	# Clean compile on GCC4
+	epatch "${FILESDIR}/pump-${PV}-gcc4.patch"
+}
+
+src_compile() {
+	make DEB_CFLAGS="-fPIC ${CFLAGS}" pump || die
+}
+
+src_install() {
+	into /
+	dosbin pump || die
+
+	doman pump.8
+	dodoc CREDITS
+
+	into /usr/
+	dolib.a libpump.a
+	insinto /usr/include/
+	doins pump.h
+
+	make -C po install datadir="${D}/usr/share/"
+}
-- 
cgit v1.2.3-65-gdbad