summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmmp/wmmp-0.9.1.ebuild')
-rw-r--r--x11-plugins/wmmp/wmmp-0.9.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmmp/wmmp-0.9.1.ebuild b/x11-plugins/wmmp/wmmp-0.9.1.ebuild
new file mode 100644
index 000000000000..a943a3a8bc8b
--- /dev/null
+++ b/x11-plugins/wmmp/wmmp-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#
+
+IUSE=""
+
+MY_P=${P/wm/WM}
+DESCRIPTION="A Window Maker dock app client for Music Player Daemon(media-sound/mpd)"
+SRC_URI="http://mercury.chem.pitt.edu/~shank/${MY_P}.tar.gz"
+HOMEPAGE="http://www.musicpd.org"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ emake install DESTDIR=${D} || die
+
+ dodoc AUTHORS COPYING INSTALL README THANKS TODO
+}