summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/guacamole')
-rw-r--r--www-apps/guacamole/ChangeLog7
-rw-r--r--www-apps/guacamole/guacamole-0.7.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/www-apps/guacamole/ChangeLog b/www-apps/guacamole/ChangeLog
index 9167c833c4e7..e019334f8d70 100644
--- a/www-apps/guacamole/ChangeLog
+++ b/www-apps/guacamole/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/guacamole
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/ChangeLog,v 1.1 2012/11/10 14:17:31 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/ChangeLog,v 1.2 2012/12/05 20:48:01 nativemad Exp $
+
+*guacamole-0.7.0 (06 Dec 2012)
+
+ 06 Dec 2012; Andreas Schuerch <nativemad@gentoo.org> +guacamole-0.7.0.ebuild:
+ version bump
*guacamole-0.6.2 (10 Nov 2012)
diff --git a/www-apps/guacamole/guacamole-0.7.0.ebuild b/www-apps/guacamole/guacamole-0.7.0.ebuild
new file mode 100644
index 000000000000..e0a93de451ad
--- /dev/null
+++ b/www-apps/guacamole/guacamole-0.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/guacamole-0.7.0.ebuild,v 1.1 2012/12/05 20:48:01 nativemad Exp $
+
+EAPI=4
+
+inherit eutils
+DESCRIPTION="Guacamole is a html5 vnc client as servlet"
+HOMEPAGE="http://guacamole.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="AGPL-3"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="vnc rdesktop"
+
+DEPEND="dev-java/maven-bin"
+
+RDEPEND="${DEPEND}
+ www-servers/tomcat
+ >virtual/jre-1.6
+ net-misc/guacd
+ vnc? ( net-libs/libguac-client-vnc )
+ rdesktop? ( net-libs/libguac-client-rdp )"
+
+src_compile() {
+ mkdir "${HOME}"/.m2
+ cat /usr/share/maven-bin-2.2/conf/settings.xml | sed -e 's:<!-- localRepo:localRepo:g' \
+ -e 's:/path/to/local/repo:'${HOME}/.m2':g' >"${S}"/settings.xml
+ mvn -s "${S}"/settings.xml package
+}
+
+src_install() {
+ sed -e 's:/path/to:/etc/guacamole:g' -i "${S}"/doc/example/guacamole.properties || die "properties sed failed"
+ insinto /etc/"${PN}"
+ doins "${S}"/doc/example/guacamole.properties
+ doins "${S}"/doc/example/user-mapping.xml
+ rm -rf /var/lib/"{$PN}"
+ insinto /var/lib/"${PN}"
+ newins "${S}"/target/"${P}".war "${PN}".war
+ elog "Please unpack /var/lib/"${PN}"/"${PN}".war in to your servlet container!"
+ elog "Please also link /etc/guacamole in to the lib directory of your servlet container."
+ elog "like this:"
+ elog "cd /var/lib/guacamole && jar -xvf guacamole.war && cd .. && cp -a guacamole /var/lib/tomcat-7/webapps/"
+ elog "ln -sf /etc/guacamole/guacamole.properties /usr/share/tomcat-7/lib/"
+ elog "You will also need to define users and connectrions in /etc/guacamole/user-mapping.xml!"
+}