summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gamer/ChangeLog10
-rw-r--r--sci-libs/gamer/files/1.4-multilib.patch2
-rw-r--r--sci-libs/gamer/gamer-1.5-r2.ebuild51
-rw-r--r--sci-libs/gamer/metadata.xml8
4 files changed, 64 insertions, 7 deletions
diff --git a/sci-libs/gamer/ChangeLog b/sci-libs/gamer/ChangeLog
index 44e0cf14b1ca..f96d87d5a419 100644
--- a/sci-libs/gamer/ChangeLog
+++ b/sci-libs/gamer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gamer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/ChangeLog,v 1.6 2012/06/19 11:19:42 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/ChangeLog,v 1.7 2013/12/06 13:03:35 jlec Exp $
+
+*gamer-1.5-r2 (06 Dec 2013)
+
+ 06 Dec 2013; Justin Lecher <jlec@gentoo.org> +gamer-1.5-r2.ebuild,
+ files/1.4-multilib.patch, metadata.xml:
+ Fix underlinking issue
19 Jun 2012; Justin Lecher <jlec@gentoo.org> files/1.5-underlinking.patch:
Fix relink problems of libtool, #421749
diff --git a/sci-libs/gamer/files/1.4-multilib.patch b/sci-libs/gamer/files/1.4-multilib.patch
index 85ccc9539839..3ebc8dcd7aab 100644
--- a/sci-libs/gamer/files/1.4-multilib.patch
+++ b/sci-libs/gamer/files/1.4-multilib.patch
@@ -11,7 +11,7 @@ index de1d7c3..b2420c8 100644
libgamer_la_SOURCES =
-libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS}
-+libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS} -lm -lstdc++
++libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS} -lm -lstdc++ ../tetgen/libtetgen.la
libgamer_la_LDFLAGS = -version-info ${FETK_VERSION}
libtriangle_la_SOURCES =
diff --git a/sci-libs/gamer/gamer-1.5-r2.ebuild b/sci-libs/gamer/gamer-1.5-r2.ebuild
new file mode 100644
index 000000000000..f4be70b11637
--- /dev/null
+++ b/sci-libs/gamer/gamer-1.5-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/gamer-1.5-r2.ebuild,v 1.1 2013/12/06 13:03:35 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Geometry-preserving Adaptive MeshER"
+HOMEPAGE="http://fetk.org/codes/gamer/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/maloc-1.4"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )"
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/1.4-multilib.patch
+ "${FILESDIR}"/1.4-doc.patch )
+
+src_configure() {
+ local fetk_include
+ local fetk_lib
+ local myeconfargs
+
+ use doc || myeconfargs+=( ${myconf} --with-doxygen= --with-dot= )
+
+ fetk_include="${EPREFIX}"/usr/include
+ fetk_lib="${EPREFIX}"/usr/$(get_libdir)
+ export FETK_INCLUDE="${fetk_include}"
+ export FETK_LIBRARY="${fetk_lib}"
+
+ myeconfargs+=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-triplet
+ --enable-shared
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/gamer/metadata.xml b/sci-libs/gamer/metadata.xml
index 210ad0db014c..5ef07a39e7e1 100644
--- a/sci-libs/gamer/metadata.xml
+++ b/sci-libs/gamer/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>