summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/ChangeLog9
-rw-r--r--net-www/mozilla/mozilla-1.1_beta.ebuild38
2 files changed, 17 insertions, 30 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 0dfee308ce4c..57be9bdc156c 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.33 2002/08/11 20:10:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.34 2002/08/27 08:11:28 wmertens Exp $
+
+ 27 Aug 2002; Wout Mertens <wmertens@gentoo.org> mozilla-1.1_beta :
+
+ Changed install so that the emerge process needs rougly 80MB harddisk space
+ less. (Which brings it down to a mere 550MB :) ) Only applied to the beta
+ because I don't want to break stuff unintentionally, but it should work for
+ the 1.0 ebuilds as well. Feel free to add it to them.
11 Aug 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-{1.0-r3,1.1_beta} :
diff --git a/net-www/mozilla/mozilla-1.1_beta.ebuild b/net-www/mozilla/mozilla-1.1_beta.ebuild
index a16cbcf639a2..13ad97c7824c 100644
--- a/net-www/mozilla/mozilla-1.1_beta.ebuild
+++ b/net-www/mozilla/mozilla-1.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.9 2002/08/16 03:01:02 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.10 2002/08/27 08:11:28 wmertens Exp $
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
inherit makeedit
@@ -97,9 +97,9 @@ src_unpack() {
# Use gtk+-2.0 as widget toolkit
if [ "`use gtk2`" ] ; then
cd ${S}/embedding/browser/gtk/src
- bzip2 -dc ${FILESDIR}/gtk2_embed.patch.bz2 | patch -p0 || die
+ #bzip2 -dc ${FILESDIR}/gtk2_embed.patch.bz2 | patch -p0 || die
cd ${S}/widget/src/gtk2
- bzip2 -dc ${FILESDIR}/gtk2_widget.patch.bz2 | patch -p0 || die
+ #bzip2 -dc ${FILESDIR}/gtk2_widget.patch.bz2 | patch -p0 || die
fi
}
@@ -239,6 +239,12 @@ src_compile() {
src_install() {
+ # Install, don't create tarball
+ dodir /usr/lib
+ cd ${S}/xpinstall/packager
+ make MOZ_PKG_FORMAT=raw TAR_CREATE_FLAGS=-chf> /dev/null || die
+ mv ${S}/dist/mozilla ${D}/usr/lib/mozilla
+
# Copy the include and idl files
dodir /usr/lib/mozilla/include/idl /usr/include
cd ${S}/dist
@@ -246,32 +252,6 @@ src_install() {
cp -LfR idl/* ${D}/usr/lib/mozilla/include/idl
dosym /usr/lib/mozilla/include /usr/include/mozilla
- # Build the Release Tarball
- cd ${S}/xpinstall/packager
- make || die
- dodir /usr/lib
-
- TODO=""
- case ${ARCH} in
- ppc)
- TODO="${S}/dist/mozilla-powerpc-unknown-linux-gnu.tar.gz"
- ;;
- x86)
- TODO="${S}/dist/mozilla-`uname -m`-pc-linux-gnu.tar.gz"
- ;;
- sparc)
- ;;
- sparc64)
- ;;
- arm)
- ;;
- *)
- TODO="${S}/dist/mozilla-`uname -m`-pc-linux-gnu.tar.gz"
- ;;
- esac
-
- tar xzf ${TODO} -C ${D}/usr/lib
-
# Install the development tools in /usr
dodir /usr/bin
mv ${D}/usr/lib/mozilla/{xpcshell,xpidl,xpt_dump,xpt_link} ${D}/usr/bin