summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/hotwayd/ChangeLog9
-rw-r--r--net-mail/hotwayd/files/hotwayd.xinetd11
-rw-r--r--net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild27
3 files changed, 23 insertions, 24 deletions
diff --git a/net-mail/hotwayd/ChangeLog b/net-mail/hotwayd/ChangeLog
index ea7dc2d81e6c..0e397687c811 100644
--- a/net-mail/hotwayd/ChangeLog
+++ b/net-mail/hotwayd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/hotwayd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/ChangeLog,v 1.16 2005/01/14 20:16:04 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/ChangeLog,v 1.17 2005/01/21 21:16:31 ticho Exp $
+
+ 21 Jan 2005; Andrej Kacian <ticho@gentoo.org> files/hotwayd.xinetd,
+ hotwayd-0.8.2-r1.ebuild:
+ Changed the xinetd file to use port 1100 by default, and service type to
+ unlisted. Also modified postinst instructions to reflect new settings. Set
+ hotsmtpd xinetd file to disabled by default. Closes bug #76593, reported by
+ Zhang Weiwu <zhangweiwu@realss.com>.
14 Jan 2005; Andrej Kacian <ticho@gentoo.org> hotwayd-0.8-r1.ebuild,
hotwayd-0.8.ebuild:
diff --git a/net-mail/hotwayd/files/hotwayd.xinetd b/net-mail/hotwayd/files/hotwayd.xinetd
index 47dd94beeb9a..65947585fa77 100644
--- a/net-mail/hotwayd/files/hotwayd.xinetd
+++ b/net-mail/hotwayd/files/hotwayd.xinetd
@@ -1,11 +1,7 @@
# default: off
# description: hotway daemon
-# - You need to add a line that says "hotwayd 110/tcp" to your
-# /etc/services file. Change the port number if necessary, see below.
-# - By default it listens to port 110 (default for pop3)
-# If you already have a pop3 server running, or you want it to listen
-# to another port change the value of "port = 110" below.
-# Change the value in your email client and in /etc/services accordingly.
+# - By default it listens to port 1100, so please adjust settings in your
+# clients
# - By default it only allows access from localhost.
# - Also all xinetd entries do not start by default.
# One should manually enable the entries that one wants by
@@ -19,10 +15,11 @@ service hotwayd
socket_type = stream
wait = no
user = nobody
- port = 110
+ port = 1100
server = /usr/sbin/hotwayd
#server_args = -p http://proxy:8080 -u proxy_user -q proxy_password
log_on_success += USERID
log_on_failure += USERID
disable = yes
+ type = unlisted
}
diff --git a/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild b/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild
index 473160bdc763..93de6501d198 100644
--- a/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild
+++ b/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild,v 1.1 2005/01/13 15:14:51 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/hotwayd/hotwayd-0.8.2-r1.ebuild,v 1.2 2005/01/21 21:16:31 ticho Exp $
inherit eutils
@@ -27,6 +27,7 @@ src_install () {
if use smtp; then
dosbin hotsmtpd/hotsmtpd
insinto /etc/xinetd.d
+ sed -i -e 's:^disable = no:disable = yes:' hotsmtpd/hotsmtpd.xinetd
newins hotsmtpd/hotsmtpd.xinetd hotsmtpd
fi
@@ -37,26 +38,20 @@ src_install () {
}
pkg_postinst () {
- einfo ""
- einfo " By default daemons that use xinetd are not started "
- einfo " automatically in gentoo"
+ echo
+ einfo " By default daemons that use xinetd are not started automatically in gentoo"
einfo " To activate do the following steps: "
einfo " - Edit the file /etc/xinetd.d/hotwayd and change disable "
einfo " from yes to no "
- einfo " - Add the following line to /etc/services: "
- einfo " hotwayd 110/tcp "
- einfo " - Note: if you already have a daemon serving port 110 (the "
- einfo " default pop3 port); then change the port number to something "
- einfo " else; also change the port number in hotwayd "
- einfo " - If you already had xinetd up and running, restart with "
- einfo " # /etc/init.d/xinetd restart "
- einfo " or "
- einfo " If the emerge also pulled in the xinetd package for you, do "
- einfo " # rc-update add xinetd default "
- einfo " # /etc/init.d/xinetd start "
- einfo ""
+ einfo " - Restart xinetd with \`/etc/init.d/xinetd restart\` "
+ echo
if use smtp; then
einfo "You chose to install hotsmtpd, a SMTP proxy for hotmail. Please"
einfo "Configure /etc/xinetd.d/hotsmtpd and restart xinetd to start using it."
+ echo
+ fi
+ einfo "Set your e-mail applications to use port 1100 for receiving email."
+ if use smtp; then
+ einfo "Use port 2500 for sending email."
fi
}