summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ldns/ldns-1.6.16-r1.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.6.16-r1.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/net-libs/ldns/ldns-1.6.16-r1.ebuild b/net-libs/ldns/ldns-1.6.16-r1.ebuild
deleted file mode 100644
index 4b56375a8103..000000000000
--- a/net-libs/ldns/ldns-1.6.16-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.16-r1.ebuild,v 1.3 2014/07/09 17:03:04 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib-minimal python-single-r1
-
-DESCRIPTION="a library with the aim to simplify DNS programming in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc gost +ecdsa python +ssl static-libs vim-syntax"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-RDEPEND="ssl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- ecdsa? ( >=dev-libs/openssl-1.0.1h-r2:0[-bindist,${MULTILIB_USEDEP}] )
- gost? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="ecdsa? ( ssl )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable ecdsa) \
- $(use_enable gost) \
- $(use_enable ssl sha2) \
- $(use_enable static-libs static) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --without-drill \
- --without-examples \
- --disable-rpath
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- prune_libtool_files --modules
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-
- einfo
- elog "Install net-dns/ldns-utils if you want drill and examples"
- einfo
-}