summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/corefonts/ChangeLog11
-rw-r--r--media-fonts/corefonts/corefonts-1-r5.ebuild48
2 files changed, 57 insertions, 2 deletions
diff --git a/media-fonts/corefonts/ChangeLog b/media-fonts/corefonts/ChangeLog
index 3d0f03f1fe40..79817dafe64e 100644
--- a/media-fonts/corefonts/ChangeLog
+++ b/media-fonts/corefonts/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-fonts/corefonts
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/corefonts/ChangeLog,v 1.34 2010/01/09 21:22:09 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/corefonts/ChangeLog,v 1.35 2011/02/23 10:11:09 robbat2 Exp $
+
+*corefonts-1-r5 (23 Feb 2011)
+
+ 23 Feb 2011; Robin H. Johnson <robbat2@gentoo.org> +corefonts-1-r5.ebuild:
+ To fully comply with the license, we need to make sure a copy of it ends up
+ on the system (and inside any binpkgs we generate). Revbump to support the
+ new LiveDVD release.
09 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
corefonts-1-r4.ebuild:
diff --git a/media-fonts/corefonts/corefonts-1-r5.ebuild b/media-fonts/corefonts/corefonts-1-r5.ebuild
new file mode 100644
index 000000000000..7cab8c198c60
--- /dev/null
+++ b/media-fonts/corefonts/corefonts-1-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/corefonts/corefonts-1-r5.ebuild,v 1.1 2011/02/23 10:11:09 robbat2 Exp $
+
+inherit font
+
+DESCRIPTION="Microsoft's TrueType core fonts"
+HOMEPAGE="http://corefonts.sourceforge.net/"
+SRC_URI="mirror://sourceforge/corefonts/andale32.exe
+ mirror://sourceforge/corefonts/arial32.exe
+ mirror://sourceforge/corefonts/arialb32.exe
+ mirror://sourceforge/corefonts/comic32.exe
+ mirror://sourceforge/corefonts/courie32.exe
+ mirror://sourceforge/corefonts/georgi32.exe
+ mirror://sourceforge/corefonts/impact32.exe
+ mirror://sourceforge/corefonts/times32.exe
+ mirror://sourceforge/corefonts/trebuc32.exe
+ mirror://sourceforge/corefonts/verdan32.exe
+ mirror://sourceforge/corefonts/webdin32.exe"
+
+LICENSE="MSttfEULA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="X"
+
+DEPEND="app-arch/cabextract"
+RDEPEND=""
+
+S=${WORKDIR}
+FONT_S=${WORKDIR}
+FONT_SUFFIX="ttf"
+
+src_unpack() {
+ for exe in ${A} ; do
+ echo ">>> Unpacking ${exe} to ${WORKDIR}"
+ cabextract --lowercase "${DISTDIR}"/${exe} > /dev/null \
+ || die "failed to unpack ${exe}"
+ done
+}
+
+src_install() {
+ font_src_install
+ # The license explicitly states that the license must be distributed with the
+ # fonts. The only way to do that for the binpkg is to include it.
+ # We just have to copy it from the portdir because it's not actually inside
+ # upstream's own files...
+ dodoc "${PORTDIR}"/licenses/"${LICENSE}"
+}