summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bzr-fastimport/bzr-fastimport-0.13.0.ebuild')
-rw-r--r--dev-vcs/bzr-fastimport/bzr-fastimport-0.13.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/bzr-fastimport/bzr-fastimport-0.13.0.ebuild b/dev-vcs/bzr-fastimport/bzr-fastimport-0.13.0.ebuild
new file mode 100644
index 000000000000..f899c30d8b1f
--- /dev/null
+++ b/dev-vcs/bzr-fastimport/bzr-fastimport-0.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr-fastimport/bzr-fastimport-0.13.0.ebuild,v 1.1 2012/03/16 23:57:21 fauli Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Plugin providing fast loading of revision control data into Bazaar"
+HOMEPAGE="https://launchpad.net/bzr-fastimport http://wiki.bazaar.canonical.com/BzrFastImport"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/bzr-1.18
+ >=dev-python/python-fastimport-0.9"
+DEPEND=""
+
+PYTHON_MODNAME="bzrlib/plugins/fastimport"
+
+pkg_setup() {
+ DOCS="NEWS README.txt doc/notes.txt"
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog "These commands need additional dependencies:"
+ elog
+ elog "bzr fast-export-from-darcs: dev-vcs/darcs"
+ elog "bzr fast-export-from-git: dev-vcs/git"
+ elog "bzr fast-export-from-hg: dev-vcs/mercurial"
+ elog "bzr fast-export-from-mtn: dev-vcs/monotone"
+ elog "bzr fast-export-from-svn: dev-vcs/subversion[python]"
+}